question

HaimKrief-3127 avatar image
0 Votes"
HaimKrief-3127 asked etwei2-4094 commented

BLE UWP get is connected false with intermittent true after updating windows to 19041.572

My VS application that worked fine until updating the windows see my BLE device but return false most of the time with very short true.
I can't connect to my devices with an application that we use in mass production line in China.
We are stuck and they can't recover to older version.

Please help,
Thanks

windows-uwp
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have some questions here. Could you please tell me what kind of project you are using? What is the BLE device that you are using?

0 Votes 0 ·

Thanks for replaying.
This is our custom medical device with BLE communication.
The base of the project is c# "Bluetooth Low Energy sample" from Microsoft.
We are using this program for 2.5 years.

0 Votes 0 ·

So have you tried to use the latest C# BLE sample to connect the BLE device? Does the official sample give the same error?

0 Votes 0 ·
Show more comments

1 Answer

HaimKrief-3127 avatar image
0 Votes"
HaimKrief-3127 answered etwei2-4094 commented

We fixed the problem.
Using the updated example didn't help still is connectable is false most of the time, it seems it is true just when get the advertise packet and immediately false.
The fix is to ignore this flag.
This obviously changed after Windows update and it's pretty major.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Please share on how you code subsequent operations such as WriteClientCharacteristicConfigurationDescriptorAsync

Thanks!

0 Votes 0 ·