question

OliverDickins-0919 avatar image
0 Votes"
OliverDickins-0919 asked ChrisH-0801 answered

RDS & UPD with Microsoft Teams

Hello!

I've got an RDS configuration with 2x RDS Servers. This setup utilized User Profile Disks and I've got a problem when signing into Microsoft Teams.
I've installed the Teams Machine-Wide installer on RDS which works a treat, all user when first logged in get Teams push into their AppData (on the UPD) and loaded at first logon.

The issue comes however a few days later, when they're assigned a different server.
When the user logs into a different server to which they originally setup Teams on, they're greeted with the following screen;
37640-image.png



This image was taken from Google Images, the error code given to my users is "80070003".

Clicking "Signing out" does nothing.
Clicking "Restart" restarts the App, you again - sign in using your email address and it heads straight back to this screen.

What I've Tried;

  • Uninstall Microsoft Teams

  • Log out & back in, which doesn't solve the issue.


  • Set the following key on the users machine; "Get-Item HKCU:\Software\Microsoft\Office\16.0\Common\Identity | New-ItemProperty -Name "DisableADALatopWAMOverride" -Value 1 -PropertyType DWORD"

  • This seemed to help at first, however the issue has returned - not letting us log in.

  • Of course - removed all cached credentials from Credential Manager

I guess when we first sign into Teams we're given some kind of "Token" for the application, which only works on the RDS server the user originally signed in to. When the user heads to the other RDS Server, they cannot use that same Token for some reason. I've tried looking for what ever file could clear this with little success, has anyone else come across the same issue?

Thanks.
Oliver.


office-teams-windows-itproremote-desktop-servicesoffice-teams-app-dev
image.png (154.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered OliverDickins-0919 commented

Hi @JeffSnyder-0562,

Does anyone else have the same issue in your organization?

To exclude the account itself, we recommend you try to login in Teams web client (https://teams.microsoft.com) in InPrivate mode and check the result.

Then, perform a clean boot to exclude whether a background program is interfering with Teams.

Moreover, make sure Teams client is the latest version.



If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello!

The problem is occurring on anyone using RDS it seems. The Web Client logs in without issue, no matter if it's in-private or normal.
I've installed the latest version of the Machine-Wide installer and created a new UPD to cause a fresh install of Teams, the issue returns.

It's highly difficult to perform a "Clean Boot" on the server which runs many services for the entire organisation. I could look at some downtime to look at it however.

0 Votes 0 ·

Hi @OliverDickins-0919,

To be noticed that User Profile Disks are restricted a single session, which means if a user is logged into one RDS host, they cannot connect to another and they cannot have more than one session active on a single host.

0 Votes 0 ·

Hello.
Yes - that is the point of user profile disks anyway.
The problem isn't connecting to two hosts at the same time. The problem seems to be switching between hosts after they've ended their session.

Login to RDS01, open Teams - everything good, Logout.
Login to RDS01 again, open Teams - everything good, Logout.
Login to RDS02, open Teams - you get the above screen, Logout.
Login to RDS01 open Teams - everything good.

0 Votes 0 ·
JasonWard-3870 avatar image
0 Votes"
JasonWard-3870 answered JasonWard-3870 published

We're having the same problem with our clients who use RDS with user profile disks. Microsoft please provide a solution to this, with our clients working remotely due to COVID this has become a serious problem.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ChristianBresch-4677 avatar image
0 Votes"
ChristianBresch-4677 answered

We have the same problem at a newly build RDS Farm. It mostly behaves the same as OliverDickins wrote above, sometimes even Outlook ist disconnected.
We found out that clearing the following folder helps to get Teams working for a while: %localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy (Folder ACL may not be deletable - thats OK) . But the problems recur when users got balanced to another Host the other day.

Hope someone has a permanent solutions for this. Strange thing is that we have other customers with with apparently identical setups, but they dont have any known problems.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

OliverDickins-0919 avatar image
0 Votes"
OliverDickins-0919 answered

@ChristianBresch-4677 @JasonWard-3870

I started a case with Microsoft regarding this.

Initially it started behaving when we started remote support, but they deduced I should try setting the compatibility mode to "Windows 8" for Teams when in the RDS.
Setting this seems to have helped - at the minute, will report back in a few days if it's still working or not as the issue comes and goes.

If it does work, might need to write a PowerShell script to set the compatibility mode of %LocalAppData%\Local\Microsoft\Teams\Update.exe to Windows 8 at user logon.
Bit of a bodge, but what can'ya do.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ManuelWinkel-7293 avatar image
0 Votes"
ManuelWinkel-7293 answered

I had the same issue with a customer on Friday. The solution was to sync the Windows Server 2019 machines into the azure ad. So if the Windows Server 2019 machines are azure ad hybrid joined, then the error does not occur anymore.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

YannickCLEVY-8483 avatar image
0 Votes"
YannickCLEVY-8483 answered

Hi,

this is not a new issue.

On RDP server with classic local user data on C, you must install the MSI of teams (wide installer).
Remember the CMD before "change user /install" and after "change user /execute", YOU MUST REBOOT.
This will install teams for each new connexion without any issues.

On RDP server with UPD (User profil disk) that's another story :
Forget the MSI you will have Teams appearing but no way to login (I think that the data are stored in a place with access rights issues)
You must install the classic Teams with the appropriate exe file (64 / 32), FOR EACH USER.
Thanksfully this one doesn't requiere admin's rights (that crazy) so you can ask user to do it, or make a script / gpo to run it on login.

This works perfectly.

Yannick

ps to MS team :
Would be great to have Teams using less memory (almost a threat by chat with 150Mo).
Also been able to desactivate AUDIO / VIDEO capability on RDP (this create user frustration, or bad usage).
Screen sharing is good, chat and filesharing, that's enought on RDP.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

77038830 avatar image
0 Votes"
77038830 answered

Anyone else who have came up with a solution yet ?

We got the same error with RDS 2019 and Profiledisks. We got 4 RDS servers in a farm.

For som users it works without problem and for some we have problem everyday

I've said to users that have trouble to use the Webbrowser at teams.microsoft.com til we got a solution

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Pushhands-6645 avatar image
0 Votes"
Pushhands-6645 answered

Same problem here. Two Windows 2019 RDS server with UPDs. Works for user on one of the servers but on the next they get the 800700003 error and can't get in. I have tried every suggestion on this board with no luck.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BPack-4771 avatar image
0 Votes"
BPack-4771 answered BPack-4771 published

This has been going on for some-time. I am following this power as-well that has some good info. https://docs.microsoft.com/en-us/answers/questions/127875/teams-on-rds-users-can39t-login.html

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ChrisH-0801 avatar image
0 Votes"
ChrisH-0801 answered JrnWalter-0340 commented

Same problem here. Two Windows 2019 RDS session hosts with UPD's. The issues seemed to start occurring after we added the second session host.

Users also get "We weren’t able to connect. Sign in and we’ll try again. Sign in” as an alternative error when they attempt to open Teams in their RDS session.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I am currently having the same issues with teams on an RDS 2019 farm with UPD. Did you solve the problem?

1 Vote 1 ·

No we weren't able to solve the problem.

i spoke to a couple of other IT guys who also had RDS 2019 farms with user profile disks and they too had the same problems with Teams.

In the end we switched users over to the Teams web app in RDS and made sure they could access the usual Teams desktop app outside of their RDS sessions. The other IT guys I spoke to also did the same.

0 Votes 0 ·

That strange, did you followed my advices above ?

I manage 3-4 farms for differents companies and we have no issue with teams.

Regards, Yannick

0 Votes 0 ·
Show more comments