question

SharayuMundhe-5705 avatar image
0 Votes"
SharayuMundhe-5705 asked ·

MFA worked on web application but not on xamarin application

Hi,
I have registered app on azure active directory for MFA, when web team used client id for MFA from web app MFA worked fine, but when we use same application from mobile then after otp verification it gives error as need admin approval. API permission in azure set as user.read(delegated permission). Why this happens as it worked fine on web, Is there is any specific things need to be implemented for mobile?


![5041-mobmfaerror2.png][1]
[1]: /answers/storage/attachments/5041-mobmfaerror2.png

azure-active-directory
mobmfaerror.png (65.4 KiB)
mobmfaerror2.png (39.1 KiB)
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

amanpreetsingh-msft avatar image
0 Votes"
amanpreetsingh-msft answered ·

@SharayuMundhe-5705, Based on the information you shared in the screenshot, I tried to track the request and confirmed that MFA was done successfully. The error occurs after MFA and it is for 'TestMFAMob2' app where admin consent is not provided. Could you please confirm if this is the same app you are using for web and mobile? I do not see any admin consent given to this app in our backend. Please try granting admin consent under API permissions section of this Application.


Please "Accept as answer" wherever the information provided helps you to help others in the community.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.