question

MrAzureAD avatar image
0 Votes"
MrAzureAD asked ·

Azure Portal Windows App (Preview) issue - Admin Grant

In the Azure Portal App (Preview), I am not able to grant admin consent to an Azure AD app.
The button typically opens a new browser window. This seems to not work with the Azure Portal app.

Anyone else had the same issue?

Greetings,
MrAzureAd

azure-active-directory
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

FrankHuMSFT-3200 avatar image
0 Votes"
FrankHuMSFT-3200 answered ·

The admin consent button should be working properly. Are you sure you have the right permissions to grant admin consent?

Which browser are you using? Can you try again now and see if it's working as intended? It may have been a transient issue with your network.

Have you checked that the permissions for your respective AAD Application Registration have been granted to the service principal/enterprise application?

You can check this by going to the enterprise application's permissions and seeing if the permissions are there or not.

Can you explain why you think it's not working properly?

· 3 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Everything works in the browser - any browser. I have the issue with the Azure Portal App (Preview) for Windows.


0 Votes 0 ·

Hi @MrAzureAD,

Is the "Grant admin consent" button greyed out or just not doing anything? Can you post a screenshot of what you are seeing?

0 Votes 0 ·

Also (sorry if this is obvious), but have you ensured that the "Grant admin consent" workflow is enabled and "Users can request admin consent to apps they are unable to consent to" is set to "Yes"? https://docs.microsoft.com/en-us/azure/active-directory/manage-apps/configure-admin-consent-workflow

0 Votes 0 ·