question

JoeYasi-7272 avatar image
0 Votes"
JoeYasi-7272 asked ·

Microphone does not work when receiving calls

I'm running Kubuntu 19.10, and I've tried teams 1.3.00.958 and 1.3.00.5153. I'm using an old Logitech B500 webcam for video and mic. Teams is configured to use my Built-in Audio Analog Surround 5.1 sound card for speakers and the Webcam B500 Mono for microphone. These are the only devices available for selection. If I place a call or join a meeting, my microphone works. If I receive a call, they only hear noise. Hanging up and having me call them back works. Why does the mic only not work when receiving calls?

office-teams-linux-itpro
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered ·

Hi JoeYasi-7272!
Does anyone else have the same issue?
Does this issue persist if you restart Teams for Linux client?
It looks like this would require some further investigation. We recommend you open a support request from https://admin.microsoft.com so that our support team can troubleshoot and assist you in resolving this issue.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JoeYasi-7272 avatar image
0 Votes"
JoeYasi-7272 answered ·

I don't know if anyone else has experienced the same issue, but I've asked the other Linux users in my organization, and I'll report back when I hear.

This issue does persist after restarting the Teams for Linux client. I will open a support request. Thanks.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JoeYasi-7272 avatar image
0 Votes"
JoeYasi-7272 answered ·

When I try to go to https://admin.microsoft.com, it just redirects me to office.com. I don't see a way to file a support ticket with Microsoft from that.

I am the only Linux user from the few I talked to experience this issue, but I believe I figured out what is happening. If I use a bluetooth headset instead of my webcam for the microphone, I do not have this problem. The issue is that the microphone in my webcam doesn't work unless the video is turned on. If I take a call without video, it also doesn't work.

Is there a difference in initialization order of video and microphone for Teams when receiving vs placing a call? If so, that could explain what I'm seeing.

Another issue: Teams holds the microphone open after the call ends. When using a noise canceling bluetooth headset, this disrupts noise cancellation since the microphones are used for that purpose. Restarting teams after the call releases that resource hold, but Teams should free the microphone when the call or meeting is over.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.