question

Piotr-8233 avatar image
0 Votes"
Piotr-8233 asked LarsBlizard-6151 published

WIN 10 Network issue

Hello

I have WIN 10 Home - 19041.630

and NAS Serwer Qnap
and second computer WIN 7


What should be set and how on win 10 site to see all the other computers, NAS.. at network.
WIN 10 also do not see themself at Network
Right now NAS appear time to time then disappeared without any reason




PS:
Of course without using SMB1.

windows-10-network
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello

As one solution, it can be avoided by registering the following batch in the task scheduler etc. and executing it automatically.

@echo off
net stop FDResPub
powershell sleep 5
net start FDResPub
exit

0 Votes 0 ·
Piotr-8233 avatar image
0 Votes"
Piotr-8233 answered

40782-net1.png




My Network schema


net1.png (137.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SunnyQi-MSFT avatar image
0 Votes"
SunnyQi-MSFT answered

Hello,

Thanks for posting in Q&A platform.

Please try the following suggestions:

First, please change your network category type as Private.

Open administrative Windows PowerShell, type/paste following and press Enter:

Get-NetConnectionProfile

If your network is Public, the NetworkCategory should mention it. Note down the Index number mentioned against InterfaceIndex. Substitute the Index number in below mentioned command and press Enter:

Set-NetConnectionProfile -InterfaceIndex <index number> -NetworkCategory Private

Execute Get-NetConnectionProfile command again to confirm if the network category is now Private.

Go to Control Panel > Network and Sharing Center > Change advanced sharing settings. Under Private network, please click the options Turn on network discovery and Turn on file and printer sharing.

Under All networks > Public folder sharing, select Turn on network sharing so anyone with network access can read and write files in Public folders.

Then, please open Services snap-in and make sure the following services are running:

Function Discovery Provider Host
Function Discovery Resource Publication
SSDP Discovery
UPnP Device Host

For more information, please refer to the following thread.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/homegroup-removed-how-to-get-network-sharing-work/01277332-2916-4a68-853a-116696b20743


Best Regards,
Sunny


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Piotr-8233 avatar image
0 Votes"
Piotr-8233 answered

Hello

I did all step by step and it does not help
Only what has been changed that myc omputer cen see i itself at network connections.
But when i restart it it bac to previous state.

Conlcusion
When i stop and start services i can see my computer itself at network connections, but after restart i back to invisiblie despite that services has been started automatically and system shows that they are runnung.

Server NAS and WIN 7 still are invisible

Any other advices?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Piotr-8233 avatar image
0 Votes"
Piotr-8233 answered

Of course when i run SMB1 I can see all computers and NAS

But of course i do not want to use SMB1
Wjen I disable SMB1 and enable SMB2 it does not work :(

So what is workaround?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SunnyQi-MSFT avatar image
0 Votes"
SunnyQi-MSFT answered SunnyQi-MSFT edited

Hi @Piotr-8233 ,

Sorry for the late reply and thanks for your feedback. If the issue can be resolved when you enabled SMBv1, then the issue is that your NAS doesn't support new version of SMB, so you need to make Windows to support old version of SMB. Or you could update the firmware of your NAS to support SMBv2/SMBv3.


Best Regards,
Sunny


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Piotr-8233 avatar image
0 Votes"
Piotr-8233 answered LarsBlizard-6151 published

Hello


Well As You cen see my qnap supports SMB 1 SMB2 SMB 2.1 SMB3. Ss there is no any issue.
Additionality Win 10 cannot see itself at network
Of course i run SMB 2 on wine 10
And additionally Win 10 is not visible by win 7 so it must be something on wi 10 side




Do You have any other ideas what can be wrong?
Of course i swiich off firewall to eliminate this cause but still nothing :(


41776-zrzut-ekranu-2020-11-23-081101.jpg



· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

i have the same issue. network discovery does not work.

0 Votes 0 ·