question

LP-8795 avatar image
0 Votes"
LP-8795 asked ·

Visual Studio 2019 ver 16.8.1: Xamarin - Error starting Android Emulator

Error:
WARNING: unexpected '-prop' value ('monodroid.avdname=pixel_2_q_10_0_-_api_29'), only 'qemu.' properties are supported
WARNING: unexpected '-prop' value ('emu.uuid=247e01dd-5fb3-47fe-92ec-b73d9583cfe3'), only 'qemu.' properties are supported

Description:
When I click on the Run button in the Android Device Manager - the error appears immediately

Note:
Before updating to version 16.8.0 and later to version 16.8.1 the android emulator worked correctly

System specifications:
OS: Windows 10 pro ver 2004 build 19041.630
Processor: Intel Core i7-8700K CPU 3.70GHz
Visual Studio: Enterprise 2019 ver 16.8.1
.NET Framework: ver 4.8.04084
Xamarin: ver 16.8.000.255
Xamarin.Android SDK: ver 11.1.0.17
Hyper-V: installed and Enabled
Windows Hypervisor Platform: Installed and Enabled


Thanks in advance

dotnet-xamarinformsdotnet-android
· 3
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This issue occurs for the new version VS and has not been fixed well. You could seed a feed back to the product team: Help -> Seed Feedback-> Report a problem. The 16.8.2 version is released now, try to update the VS and test again.

0 Votes 0 ·

i downloaded the version 16.8.2 but the error still exists.

0 Votes 0 ·

Hi, I update the VS to the version 16.8.2 and doesn't face the isue when deploying a project. Try to reset the emulator: Android Device Manager ->Edit -> Factory Reset. Or create a new emulator and test.


0 Votes 0 ·
LP-8795 avatar image
1 Vote"
LP-8795 answered ·

I have found the solution.
The problem was caused by the video card (AMD Radeon RX580) with outdated drivers.
Update the drivers with "AMD Adrenalin 2020 Edition" and reboot.
Run the android emulator and if you get a GPU error set hw.gpu.mode = off in the emulator properties.
With these steps I solved. I hope they are useful to you too.
Regards

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

NikolaRadosavljevic-2855 avatar image
0 Votes"
NikolaRadosavljevic-2855 answered ·

Happens to me as well. I have 16.8.2
Following installed:
43131-image.png

One specificity is that I run it in Windows 10 Pro machine (with Hyper-V) which is hosted on a Windows 2019 server hypervisor with nested virtualization enabled.



image.png (36.5 KiB)
· 4 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Nikola i installed 16.8.2 too a few days ago but the error still exists

0 Votes 0 ·

Does it work after 'Factory Reset'? Add will this issue occur for all the emulators? Try to deploy the project in a physical device to check if it will work.

0 Votes 0 ·

yes I tried both with factory reset and to delete and recreate the emulators but the error still exists. The error appears only with Android emulators but on physical devices it works. Furthermore, even running the emulator from device manager I have the error not only from debugging.

0 Votes 0 ·

Try to repair the IDE. If it still doesn't work, please test the project on the physical device first and report the issue to the VS product team.


0 Votes 0 ·