question

erickfear avatar image
0 Votes"
erickfear asked FionaYan-MSFT commented

SCCM 2012r2 OSD error no required deployment

Hi all,
I'm facing a issue with OS deployment. Workstations are in constant loop of boot/reboot.
Network drivers are loaded , connection to MP is there, TS is distributed to DP's, TS deployed to all unknown workstations (workstations mac are removed from sccm)

Log :
Processing Policy Assignment DEP-TLA200AC-ScopeId_EDA71B31-FBCD-4410-8C30-9A502D34CE0F/Application_edd0c8d1-412c-4045-b5ff-9e8c7a9204e4. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Processing Policy Assignment DEP-TLA200AC-ScopeId_EDA71B31-FBCD-4410-8C30-9A502D34CE0F/Application_ef714674-3216-442b-9aaa-21bc7e01a3f0. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Successfully read 146 policy assignments. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Downloading policy body TLA200AC-TLA002FD-6F6BCC28. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Preparing Policy Body Request. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Setting transport. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Setting policy location = http://<mp>/SMS_MP/.sms_pol?TLA200AC-TLA002FD-6F6BCC28.1_00. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Executing Policy Body Request. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL: sccm.domain.zzz:80 GET /SMS_MP/.sms_pol?TLA200AC-TLA002FD-6F6BCC28.1_00 TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Not in SSL. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Request was successful. TSMBootstrap 11/26/2020 3:29:58 PM 1664 (0x0680)
Found a secure policy. TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Trying to decode policy. TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Policy decoded. TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Expected Hash size: 32, Computed Hash size: 32 TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Request location: HTTP://<MP>/SMS_MP/.SMS_POL?TLA200AC-TLA002FD-6F6BCC28.1_00 TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Response ID: TLA200AC-TLA002FD-6F6BCC28 TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Reading Policy Body. TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
Parsing Policy Body. TSMBootstrap 11/26/2020 3:29:59 PM 1664 (0x0680)
This Task sequence is set for DownloadOnDemand TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Active daylight bias: 0 min TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
m_spPolicyObjectNode.selectNode( sXPath, &spValueNode ), HRESULT=80070002 (..\tspolicy.cpp,2846) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Is active time for TLA002FD task sequence later than current time? Current time: 2020-11-26 13:30:00.040. Active time: 2020-11-26 11:55:00.000. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
This Task sequence is set for DownloadOnDemand TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Active daylight bias: 0 min TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
m_spPolicyObjectNode.selectNode( sXPath, &spValueNode ), HRESULT=80070002 (..\tspolicy.cpp,2846) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Is active time for TLA002FD task sequence later than current time? Current time: 2020-11-26 13:30:00.087. Active time: 2020-11-26 11:55:00.000. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Retrieving collection variable policy. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Found 0 collection variables. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Retrieving machine variable policy. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Found 0 machine variables. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Setting collection variables in the task sequencing environment. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Setting machine variables in the task sequencing environment. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Exiting TSMediaWizardControl::GetPolicy. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
!IsTaskSelectionRequired(), HRESULT=80004005 (tsmediawizardcontrol.cpp,2496) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Failed to run unattended because there is no required deployment. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Unattended(), HRESULT=80004005 (tsmediawizardcontrol.cpp,2857) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
oTSMediaWizardControl.Run(sMediaRoot, true, sTSLaunchMode), HRESULT=80004005 (tsmbootstrap.cpp,1104) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Failed to run executing from media in WinPE TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Execute( eExecutionEnv, sConfigPath, sTSXMLFile, uBootCount, bReloadEnv, &uExitCode ), HRESULT=80004005 (tsmbootstrap.cpp,1291) TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Exiting with return code 0x80004005 TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)
Execution complete. TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
hMap != 0, HRESULT=80070002 (..\environmentscope.cpp,493) TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
m_pGlobalScope->open(), HRESULT=80070002 (..\environmentlib.cpp,335) TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
this->open(), HRESULT=80070002 (..\environmentlib.cpp,561) TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
::RegOpenKeyExW (HKEY_LOCAL_MACHINE, sKey.c_str(), 0, KEY_READ, &hSubKey), HRESULT=80070002 (..\utils.cpp,1102) TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
RegOpenKeyExW is unsuccessful for Software\Microsoft\SMS\Task Sequence TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
GetTsRegValue() is unsuccessful. 0x80070002. TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
End program: TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
Finalizing logging from process 528 TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
Finalizing logs to root of first available drive TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)
LOGGING: Setting log directory to "X:\SMSTSLog". TSBootShell 11/26/2020 3:30:00 PM 816 (0x0330)

mem-cm-osd
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

FionaYan-MSFT avatar image
0 Votes"
FionaYan-MSFT answered FionaYan-MSFT edited

@erickfear
Thank you for posting in Microsoft Q&A forum.

Could we know which steps we are in constant loop of boot/reboot during our task sequence process?If it is convenient for us, could you provide a screenshot?

Have a nice day!



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erickfear avatar image
0 Votes"
erickfear answered FionaYan-MSFT edited

Hi,
We are before Task sequence selection. So all, I can see is a Windows logo (WinPe) and then reboot.
I've removed PXE boot from DP and recreated it, sending x86 and x64 boot image, booting from usb generate same result.
But as I mentioned there's a connection to MP from station.
regards

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@erickfear

From the situation we described,maybe we could use one machine for test to dig and then we may find the way.Here are two methods i thought maybe we could do,and we may troubleshoot our network driver first.

  1. Since we go into the Winpe,we could try to press F8 and then the boot process will stop,we could check the detailed connection that we want to check,like the network is really works or not.

  2. To check the network connection ,we could recreate new virtual machine and repeat our operation on our physical machine,if it is ok,maybe the network driver issue.


Have a good day !

0 Votes 0 ·
erickfear avatar image
0 Votes"
erickfear answered FionaYan-MSFT edited

Hi
Thank You for quick answer. As I mentioned, from WinPe I could ping management point. I will of course check if all necesery ports are opened.
regarrds

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@erickfear

1.Yes,we could ping the MP,our network connection is ok,could we know the ADK version is match our ccm?Sometimes ,it may cause the reboot issue.

2.If the ADK version is ok,at this situation we may also need to recreate new virtual machine and repeat our operation because this is an important step so that we could see if our task sequence is normally or not?

3.Have we enable the option"allow unattended operating system deployment"?Here is a similar situation may for you to refer to:
https://systemcenterguru.wordpress.com/2013/10/16/cannot-see-list-of-task-sequences-when-booting-with-task-sequence-media/

Note:This is non-official Microsoft article for you to refer to.

43875-unattended-operating-system-deployment.png


Have a good day!


0 Votes 0 ·
GaryBlok avatar image
0 Votes"
GaryBlok answered

You have a Required OSD Task Sequence Deployed to all Unknown Computers? So if someone came into your Organization, plugged in a computer, PXE Boot, it would image with your OSD Image?

I've never done Required OSD Deployments that way, but I've done a lot of Required Deployments, and it's always worked when:
I create a Required OSD Collection
I deploy the Task Sequence as Required to the Required OSD Collection
I import a computer object into the Required OSD Collection
PXE Boot (or USB Media) will automatically start the Required Task Sequence.

You can see in your log that the machine isn't finding the deployment.
- Failed to run unattended because there is no required deployment. TSMBootstrap 11/26/2020 3:30:00 PM 1664 (0x0680)

Do available deployments work to unknown computers?

I would test importing your test machine into a collection with the TS Deployed to it. If you can get that to work, then at least you can rule out your boot media, and your Task Sequence Deployment setup.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erickfear avatar image
0 Votes"
erickfear answered

Hi all,
Thx for support.
I have few Task Sequence deployed to unknown computers, this option worked.
Right now we are despaired to leave PXE boot and work only on USB.
We are at point where creating small usb "Bootable media" does not work we have same problem as with pxe boot.
If I create "stand-alone media" - this deployment works.
Log indicate that there are no deployments on MP, could it be a connection to MP ?
"Failed to run unattended because there is no required deployment."
Workstations are removed from SCCM.
Users can connect to MP via http://SERVERNAME/sms_mp/.sms_aut?mplist and getlist of MP's.
Those deployment worked recently. Might it be that some ports are blocked, DHCP option is missing ?
regards

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GaryBlok avatar image
0 Votes"
GaryBlok answered

Did you run the test I recommended and if so, what were your results?

I would test importing your test machine into a collection with the TS Deployed to it. If you can get that to work, then at least you can rule out your boot media, and your Task Sequence Deployment setup.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erickfear avatar image
0 Votes"
erickfear answered

Hi all,
Importing machine and deploying TS to this group did not helped, there were no duplicated GUID's or MAC accresses.
Creating bootable USB, well that's not helping as well as we stuck in this constant loop of reboots.
ADk is 10.0.18362.0 client ver 5.00.8968.1042.
Available deployments or required deployments does not work, we do not even have option to chose TS. Workstation reboots before that, like it's missing network drivers. But they are in boot image and we can ping MP from winpe env.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erickfear avatar image
1 Vote"
erickfear answered FionaYan-MSFT commented

Hi all,
We can close this case, it turn out that network team closed ports on some locations.
regards Adam

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@erickfear

Thank you very much for the update and we're glad the problem is solved now. If you have any questions in future, we warmly welcome you to post in this forum again.


Have a nice day!

0 Votes 0 ·