question

MarkoBlanko-0857 avatar image
0 Votes"
MarkoBlanko-0857 asked ·

Incorrect dates in emails using Outlook for Mac 2019 Version 16.43

Recently upgraded to Catalina and the most recent version of Outlook for Mac 19. Have not upgraded to the "New Outlook" as I still have a large number of IMAP accounts.
Mostly works the same as before with few issues, but recently noticed new emails being created with incorrect dates. Just created a new email and it is dated December 31, 2020. On top of it all, old emails are all now dated December 31, 2020. Very odd. I checked all my date preferences, which are fine. Re-indexed Spotlight just to be sure.

Also, the ability to set columns for Date Sent and Date Received are now gone, this was very useful. Now there's only Date.

Any help appreciated.

office-outlook-itprooffice-deploymentoffice-for-mac-itprodotnet-macos
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The issue is more related to Outlook client, in oder to solve it better, I added the Outlook tag, thanks for your understanding.

0 Votes 0 ·
JadeLiang-MSFT avatar image
0 Votes"
JadeLiang-MSFT answered ·

Hi @MarkoBlanko-0857 ,

new emails being created with incorrect dates

Could it display the correct time if you double-click the message to open it?
Did this issue occur with all accounts in your client or the specific account? And could your system time display normally?
Could it be reproduced if you create a new message in your web mail?

  • I have tried to send messages on my Outlook for Mac, but the date time in my message is correct with no issue. I also have researched a lot about your issue and found a similar thread which mentioned that the issue may be affected by the setting of time/date format, it's suggested to change your setting as mentioned above to check if it could also be helpful to you(System Preferences> Language and region).

  • If the issue still exists, in order to avoid the corrupted database, please try to create a new identity and switch to new user to test if the issue has any difference(System Preferences --> Create a New User in Accounts)

Besides, if the issue only happen to the specific account and it could be reproduced in your web mail, the issue may be related to you account itself.

the ability to set columns for Date Sent and Date Received are now gone

Does it mean that there's no option of "Date Sent" in your column setting or you have configured them but it couldn't work on your client? It's suggested to first check if you have checked these options via View > Columns >Date sent , if it doesn't work, based on your description, I'm afraid it may be caused by the corrupted outlook client, so please try to uninstall your client and reinstall it to check.

If your issue has any update, please feel free to post back.


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @MarkoBlanko-0857,
Does this issue have any updates? If it has been resolved, please click "Accept as answer" to mark useful post or share your solution, your action would benefit others who have similar issues. If you have any questions or need further assistance, please feel free to post back. Thanks!

0 Votes 0 ·
TiagoLusdeVilhenaTeixeiraGuerra-0320 avatar image
0 Votes"
TiagoLusdeVilhenaTeixeiraGuerra-0320 answered ·

Hi JadeLiang,


I have Outlook for Mac 16.47 (21031401), and am experiencing a very similar problem: all emails seem fine in their mailboxes, and in the webmail.
However, when I search for a specific word (or words), the search returns all received emails with correct dates and all sent emails with "1 Jan 2001".

Trying to answer all the questions you put above:
1) Cannot reproduce problem in webmail (search in webmail returns all dates correct);
2) yes, issue occurs with all accounts (only the one I use);
3) I also have only "Date" do choose in the View > Columns. Date Received and Date Sent are not options any longer. Could this be related to the problem? I thought it was just some strange choice from MSF.

I also looked at what you suggested with the Language Settings for Outlook (I have macOK Big Sur), hence tried changing the language to English, to Portuguese, to Portuguese from Portugal, to English from UK, all to no avail.

Anything else I can try?
Thank you in advance!

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TiagoLusdeVilhenaTeixeiraGuerra-0320 avatar image
0 Votes"
TiagoLusdeVilhenaTeixeiraGuerra-0320 answered ·

Hi JadeLiang,


I have Outlook for Mac 16.47 (21031401), and am experiencing a very similar problem: all emails seem fine in their mailboxes, and in the webmail.
However, when I search for a specific word (or words), the search returns all received emails with correct dates and all sent emails with "1 Jan 2001".

Trying to answer all the questions you put above:
1) Cannot reproduce problem in webmail (search in webmail returns all dates correct);
2) yes, issue occurs with all accounts (only the one I use);
3) I also have only "Date" do choose in the View > Columns. Date Received and Date Sent are not options any longer. Could this be related to the problem? I thought it was just some strange choice from MSF.

I also looked at what you suggested with the Language Settings for Outlook (I have macOK Big Sur), hence tried changing the language to English, to Portuguese, to Portuguese from Portugal, to English from UK, all to no avail.

Anything else I can try?
Thank you in advance!

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.