question

Keith-8403 avatar image
Keith-8403 asked ·

Kudu refuses to build .NET Core 3.1 app

I recently decided to upgrade my Azure App Service app from .NET Core 3.0 to 3.1. I made sure all project files referenced the .NET Core 3.1 versions of libraries, set the targetFramework in my .csproj file to netcoreapp3.1, and set the Major/Minor Version to 3.1.0 in App Service -> Configuration -> General Settings -> Stack Settings.

However, when I pushed my 3.1 code to Azure, Kudu refused to build it: Platform 'dotnet' version '3.1' is unsupported. Supported versions: 1.0.16, 1.1.14, 2.0.9, 2.1.13, 2.2.7, 3.0.0.

It builds and runs perfectly fine on my laptop, why won't Kudu even try to build it?

azure-webapps
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

SuwatBodin-7965 avatar image
SuwatBodin-7965 answered ·
Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.