question

Christine-0243 avatar image
9 Votes"
Christine-0243 asked AndrewLittle-5495 answered

In MS Teams for linux, microphone stopped working

I installed MS Teams for Linux on Ubuntu 20.04 a few weeks ago. It worked perfectly well, until earlier this week, the microphone stopped working. I have a mic in my headset, and a mic in the Logitech camera, both work ok for all applications, except with Teams. When I use the mic, I see the record sound meter in Ubuntu sound record it, but the Teams sound meter in "settings" doesn't.
What can I do?

edit:

This morning, audio worked on MS Teams. But when the meeting actually started, a popup appeared saying "your microphone does not work" and it stopped working. It must be a bug in MS Teams, otherwise it couldn't have worked for the first 5 minutes.

office-teams-linux-itpro
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have exactly same issue, If I try to use external camera with build in microphone (Logitech c925e) mic is randomly failing in Teams (1.4.00.4855). When I open sound settings during call they are frozen and mic stops working permanently till call is restarted...

0 Votes 0 ·

Similar issue here on Kubuntu 18.04. The microphone on the USB headset is visible in the Pulse Audio Volume Control, however it would not appear in the recording tab when trying to use Teams. It was as if it could not find the microphone. In the devices section in Teams settings, there were no microphones to select. Sometimes closing (Quit) Teams for 10 minutes would see the microphone reappear, sometimes it took a few attempts.

Today however the microphone would not appear, I tried down grading with sudo apt install teams=1.3.00.30857 restarting teams but still no microphone, then upgrading with sudo apt install teams=1.4.00.7556 and restarting Teams - nothing worked, no microphone found.

I then uninstalled teams sudo apt remove teams, removed the folder ~/.config/Microsoft/Microsoft Teams/, installed Teams sudo apt install teams=1.4.00.7556 and after logging in - it worked. Whew!!!













0 Votes 0 ·
JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered SimonAlexanderAlsing-5896 edited

Hi @Christine-0243,

Does this issue persist when using Teams web client?

Please make sure you are login as a root user to your system GUI and not as some other user. Then check if you have installed the pulseaudio and ensure they are running in your environment. For more details about it, you can refer to this blog:

http://freemindscafe.com/t/microphone-not-working-with-microsoft-teams-on-ubuntu-solved/1232



If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This isn't a solution. Running a web-facing application like Microsoft Teams as root is not secure and puts the entire system and all users at severe risk.

2 Votes 2 ·

I am using the linux client, not the web client. Pulseaudio is installed. I don't want to run ms teams as root.

What happens is I see audio devices in settings, both my headphone, the built-in audio and my mic and camera, but I can't set the volume of any at a value other than zero. I drag the slider, but it goes back to zero. Audio on my computer works fine with slack and skype and other applications. And it did work with MS teams for the first week or so.

1 Vote 1 ·

This sounds like a MS solution from the NT days 20 years ago. "Just make your user an Administrator" was what you had to do when you wanted to access any non-trivial functionality. Apparently they haven't learned anything.

0 Votes 0 ·

@JimmyYang-MSFT You must be kidding. It is worst of worst practices to run as root - certainly also when this is a freaking messaging client. God please save us from "Microsoft logic" and teach them how to code. I'm experiencing the same issue, but I would rather go back to writing letters by hand than give root access for Microsoft.

Edit: and wow, it was not only the client itself but logging into the system as root. Wow you are a moron.

0 Votes 0 ·
MainUser-9607 avatar image
8 Votes"
MainUser-9607 answered tawek76-5501 commented

I had the same problem. Here is how I solved this:
If not already installed, install the PulseAudio volume control tool (sudo apt install pavucontrol)
Then, while Microsoft Team is running, open the "PulseAudio volume control" application.
Go in the Recording tab: you should see a mic volume slider for "Skype" (The Skype engine is probably used in Microsoft Team).
(If you don't see "Skype", be sure "Applications" is selected in the dropdown at the bottom of the Recording tag.)
Move the slider just a little to the right or to the left.
Then redo a Call Test in Teams. Now it should work.
After that, you can put back the slider exactly where it was, at 100% (0dB) and close the PulseAudio tool.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It works ! Thank you

1 Vote 1 ·

It works! recently i turned off skype in those settings and when i tried using MS teams the mic was't working. I didn't know that skype is actually MS teams input. Your answer saved my job interview!

0 Votes 0 ·

I'm using Jabra Evolve 20.
Actually in my case the problem was that teams selected "monitor of output of the headset" not actual "input". If found the problem using pavucontrol, because what teams reported in device settings was not true.

pavucontrol is only utility that allowed to change that setting per application.
Thanks for hint, it worked!

Now if MS could incorporate a fix... it is clearly a bug in Teams 1.4.0.13653 Ubuntu 20.04.2

0 Votes 0 ·
SimonAlexanderAlsing-5896 avatar image
0 Votes"
SimonAlexanderAlsing-5896 answered

@Christine-0243 I got the same issue, it was happening a bit before I upgraded to fedora 34, but not as persistent and often as now. fedora33-34 upgrade changed from pulseaudio to pipewire. I don't know if that relates to your situation, but I think that it might have something to do with that change.

So I tried to start the application with pw-jack teams and my first call went flawlessly, maybe it is a solution ? I'll report back when I've tested it some more.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JonG-5296 avatar image
0 Votes"
JonG-5296 answered

I have the same issue for Debian with pulseaudio.

Problem occurs somewhat randomly, but often will occur if I have a missed call, or answer an incoming call rather than a meeting.

As a workaround, quit Teams before your meeting and restart it. In fact, I often restart Teams after a meeting so that it is ready for the next meeting.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RicPeterson-5637 avatar image
0 Votes"
RicPeterson-5637 answered

I'm having the same issue running Teams Preview Linux client on Manjaro 5.10 (and 5.12). The microphone had been working up until a couple of weeks ago, but now I get the message "Your microphone isn't working". When I run Teams through my web browser (Chrome) the mic works fine. The mic also works fine in other apps such as Zoom.

I tried the "solution" above, adjusting the mic level for the app in the Pulse Audio app, but that didn't make any change in how it operated in Teams. Any other solutions?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Markus-5156 avatar image
0 Votes"
Markus-5156 answered

I have the same issue for Debian 10 with pulseaudio.

teams: 1.4.00.7556

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DavidAdelson-8521 avatar image
0 Votes"
DavidAdelson-8521 answered

I have no answer, only the same problem Ubuntu 20.04 none of my microphones works with Teams but they all work with Zoom, Discord, etc...I have tried the solution using the pulseaudio volume controller and it did not work. Teams consistently shows my microphone (Dell Latitude 5491 laptop) as not working. It's not a Linux thing or a hardware thing, its a Teams thing.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

lomo avatar image
0 Votes"
lomo answered lomo published

Downgrade of MS Teams from 1.4.00.7556 to 1.4.00.4855 resolved the issue for me.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

lomo avatar image
0 Votes"
lomo answered

Downgrading the MS Teams from 1.4.00.7556 to 1.4.00.4855 resolved the issue for me.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ChristianWichmannMoesgaard-3326 avatar image
0 Votes"
ChristianWichmannMoesgaard-3326 answered

I'm having this problem, too, and I've had it for about half a year.

The volume adjustment seems to work, but frankly there's always a new solution. It can be anything from adjusting the volume to restarting the computer to making sure not to run Citrix at the same time or any combination of them.

The list of inputs and outputs is sometimes entirely empty as well for no apparent reason. The list of inputs and outputs also does not update if I plug in or plug out an extra microphone or headset.

The Teams Linux client is outrageously bad... :/ I really appreciate the effort, but there's got to be some more effort put in here. These errors are common and easy to reproduce.

Pop!_OS 20.04, Ryzen 5900X, RØDE microphone, Logitech webcam microphone, Steelseries Arctis Pro Wireless, a friggin' Valve Index headset microphone - you name it. The microphone doesn't matter.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.