question

PaulF-0391 avatar image
1 Vote"
PaulF-0391 asked irr-1746 commented

RDP Works PC to PC, but I get Error Code 0x204 MAC to PC

I am able to remote into my Windows 10 PC fine from another Windows PC. However, when I attempt to remote in from my MAC OS running High Sierra 10.13.6 using the Microsoft Remote Desktop for MAC I get Error Code 0x204. Can anyone help?

remote-desktop-servicesremote-desktop-client
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Have you checked if the answer helps?

If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

0 Votes 0 ·

Hi, do you have any further question? Does the information provided help you?

0 Votes 0 ·
ElevenYu-MSFT avatar image
0 Votes"
ElevenYu-MSFT answered

Hi,

Error code 0x204 might be caused by serveral different reasons. So, you can try below methods to see if they help.

  1. On the remote windows PC, open "Run" and input "SystemPropertiesRemote.exe" to open up the System Properties screen.
    Make sure you have checked "Allow remote connections to this computer", and uncheck "Allow connections only from computers running Remote Desktop with
    Network Level Authentication" if your MAC pc is on the different network from the windows pc.

  2. Allow Remote Deskstop through Windows Firewall. From both sides, you must ensure the firewall allows the remote desktop connection. Since the windows PC canbe
    remoted from another windows PC. There should be no problem from the widnows side, you should check from the MAC side.

  3. Ensure 3389 port is open from both sides. On your case, you should pay more attention to mac side. (Network Utility > Port Scan > Only test ports betwee 3389 and
    3389). Or maybe you need to also assure the router is configured to forward the remote desktop port 3389.

  4. If all above methods do not help, remove the temp folder of Remote Dekstop for mac (close the remote desktop app > Finder > search "group containers" > delete
    UBF8T346G9.com.microsoft.rdc by right-clicking and choosing Move to bin from the context menu > restart your MAC pc)

  5. The last method you can try is to reinstall the app or install the latest version of the microsoft remote desktop app for mac.
    https://apps.apple.com/us/app/microsoft-remote-desktop/id1295203466?mt=12

Thanks,
Eleven


If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.







5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

PaulF-0391 avatar image
0 Votes"
PaulF-0391 answered

Unfortunately I continue to receive the 0x204 when attempting to RDP from my High Sierra MAc to my WIn10 Pro Desktop. Just to restate, I am able to RDP from my Win10 laptop to the Win10 Pro Desktop.

  1.  I did verify I the Uncheck  "Allow connections only from computers running Remote Desktop with Network Level Authentication"
    
  2. I confirmed the MAC firewall allows remote desktop connections

  3. I verified port 3389 is open from the MAC side and that my router forwards to remote desktop to port 3389. The results of my MAC scan are below:

     Port Scan has started…
    
        Port Scanning host: 10.0.0.31
    

Open TCP Port: 3389 ms-wbt-server
Port Scan has completed…

4 I deleted UBF8T346G9.com.microsoft.rdc and restarted my MAC, it still didn't work.
5. I deleted and reinstalled the app, still same error 0x204

   We couldn't connect to the remote PC. Make sure the PC is turned on and connected to 
   the network, and that remote access is enabled.

   Error code: 0x204
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

PaulF-0391 avatar image
0 Votes"
PaulF-0391 answered ElevenYu-MSFT commented

I figured it out this morning. When entering the PC name in the Remote Desktop App on my MAC, it worked when inputting the IP Address of my Win10 Pro PC rather than the actual PC Name. For some reason, the App did not recognize the PC Name, even though i confirmed it was correct and added/re-added countless times.

Nevertheless, problem solved! Thanks for your suggestions.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Glad to hear that the problem is solved. If PC name cannot be connected, it might be some DNS resolution issue from your MAC side. You can do a check.

0 Votes 0 ·
AramBasmadjian-5400 avatar image
0 Votes"
AramBasmadjian-5400 answered NandiDS-3866 edited

I am having the same problem. I running Mac OS11 (Big Sur) on a M1 Mac mini. I am using Sonicwall Mobile Connect to connect to make the VPN connection to my PC at work and that is working. However, when I connect with Microsoft Remote Desktop, I get the 0x204 error. I have unchecked "Use system proxy configuration" and also unchecked "Use hardware acceleration when possible".

I was unable to access the Group Containers or locate the UBF8T346G9.com.microsoft.rdc file. It appears that this has changed in OS11 Big Sur. Also, the Network Utility no longer exists so I am unable to verify the port. Apparently this can still be done through the Terminal, but I have no knowledge of how to do this.

I am able to VPN in and use Remote Desktop from my home on Windows PC to get into my work computer, so I know that the computer at work is set up correctly and that my router at home is not blocking the connection.

· 7
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Same here exactly - Group Containers or locate the UBF8T346G9.com.microsoft.rdc file

Did you got any chance to fix it mate ?

I am struggling here.

0 Votes 0 ·
AramBasmadjian-5400 avatar image AramBasmadjian-5400 GunaranjanSundararajan-4477 ·

No luck, my friend.

0 Votes 0 ·

Same here. This just doesn't work properly on Big Sur. Microsoft needs to remove BIg Sur as being compatible.

0 Votes 0 ·

I am having the same problem with the Remote Desktop app and the suggestions above. It does not seem to fall into the same structure. I need to access a RDS through my phone's hotspot through a whitelisted IP address. This address changes and I change the allowed IP each time, but the Remote Desktop app will not connect and I get error code 0x204.

0 Votes 0 ·

Aram,

I have the same mac computer and mac os. Seems that my mac side is ok since I can connect to a Windows 7 pc on the same network just not my Windows 10 Pro laptop. Just upgraded my key to pro to do this so I am quite disappointed.

No group containers here and can't check the port but since it works to the Windows 7 PC I am quite confused!

Struggling too!

0 Votes 0 ·

Seems like my problem is on the Windows 10 side. I just checked and I can connect W10 to control W7 but not W7 (or Mac) to control W10.
I followed all the instructions to setup the W10 to receive connections. :(

0 Votes 0 ·

Im having the same problem running Mac OS12 (Monterey) on an M1 MacBook Pro.

I haven't checked the problems on the server since I can connect from any Windows 10 or windows 7 machine to the server.

I found Group Containers and UBF8T346G9.com.microsoft.rdc in (Macintosh HD > Users > <MyUserName> > Library > Group Containers).
According to troubleshoot above I had to delete the folder, restarted application, still couldn't connect error 0x204.

I also try to connect using OpenVPN, I can see other networked devices and the server does respond to pings, so I'm almost certain it isn't the VPN.
Once in office I will try to check from local network without a VPN.

I do realise couple of months had passed since the original comment, did anyone found anything useful?

0 Votes 0 ·
VicD-1530 avatar image
0 Votes"
VicD-1530 answered

Have you tried using Remote Assistance Invitation? You can check out the steps here under Fix #4:
https://softwaretested.com/mac/how-to-fix-remote-desktop-error-code-0x204-on-a-mac/


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Krel-0470 avatar image
3 Votes"
Krel-0470 answered GiuMor51-4380 published

I found a solution for the issues I was facing.

Bought a new MacBook Air with Apple M1 chip and migrated the MacBook from old to new. VPN and Microsoft RDP worked flawlessly on my old Mac, but didn't work at the new MacBook; exact same settings for VPN and RDP.

I had my IT guy look at it and he found a solution:

in Mac > Settings > Network you see the circle with three dots in the bottom left > set order .... (I have Dutch language, so not sure what it is in English) and change the order to have VPN on top, above wifi/Lan.
This worked for me!


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I don't see the VPN in the reorder list. Just the wifi and Thunderbolt. But I do see the VPN in my list under network.

0 Votes 0 ·

THIS! After months of not being able to use my VPN on my M1 Mac, or even on my Intel Mac once I upgraded to Monterey (Mac OS12), I decided to search one more time on RDP error 0x204, and I found this solution and it fixes the problem. Once you have created the VPN connection and have it saved, and are able to start the VPN connection without any errors, yet RDP is failing with 204, open "Network Preferences..." and at the bottom of the left pane, select options, and then the choice to "Set Service Order...". I had to stop and start the VPN and it changed the order, then I set it again and it stayed in the correct order the second time, with the VPN listed above the WiFi (when it is connected), and my RDP once again works. A huge thank you to Krel-0470 for posting this solution.

0 Votes 0 ·

I have been struggling with this problem for months, following all the indications found on the net, but to no avail.
Now, with this tip, I solved it quickly and well.
Thanks Krel-0470 for your valuable report.

0 Votes 0 ·
Fachasaurus-3017 avatar image
0 Votes"
Fachasaurus-3017 answered Fachasaurus-3017 edited

New post as this thread is a year old.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Didier-9664 avatar image
0 Votes"
Didier-9664 answered irr-1746 commented

@JimHouston-9219
macOS User Guide : macOS Monterey 12

You can’t change the order of virtual private network (VPN) connections because they already take priority over non-VPN connections.

Personally i’m not able to change the order.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I am having a similar issue.
VPN does not appear in Service Order list.

I can connect to workstations, but cannot connect to any Windows Server.

Every time I try to connect to a windows server, I get the error message 0x204.






0 Votes 0 ·

I tested my setup a bit more.
We use FortiClient VPN.
I uninstalled the latest version and installed an older version (6.4.7)
Now everything works great.


I am not sure if its a configuration difference between the older version and the newer one, or if the newer 7.X version of forticlient is missing some feature which cannot be fixed via configuration.

I would suggest others look into their VPN setup.

Does anyone know if there is a difference between connecting via RDP to Windows Servers (2012r2,2016,2019) or connecting to workstations (W7,W10,W11)? Don't they use the same port?
Because I am able to connect to workstations but not to Windows Servers with the newer FortiClient versions.

0 Votes 0 ·