question

PeterHawes-7097 avatar image
0 Votes"
PeterHawes-7097 asked PeterHawes-7097 commented

Unsupported Segment Type returned on GraphAPI callRecords

I have an active GraphAPI subscription to /communications/callRecords which is successfully returning the callid for calls. When attempting to get the call details using the following request:

https://graph.microsoft.com/beta/communications/callRecords/45578cfe-8329-48b7-ba6b-54a627b00bf4?$expand=sessions($expand=segments)

I receive the following error:

 {
     "error": {
         "code": "BadRequest",
         "message": "Unsupported segment type. ODataQuery: /communications/callRecords/45578cfe-8329-48b7-ba6b-54a627b00bf4",
         "innerError": {
             "date": "2020-11-24T12:34:11",
             "request-id": "277b4fa1-11a5-4922-94d7-83fec3a57572",
             "client-request-id": "277b4fa1-11a5-4922-94d7-83fec3a57572"
         }
     }
 }

I get the same error if I change the GraphAPI call to /v1.0/. I am sure this worked previously but can't seem to work out what may have changed.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Have you tried created new subscription and still can you repro the issue as well?

0 Votes 0 ·

Yes, I have recreated the subscription on both /beta and /v1.0 and can still reproduce the error. The error is also returned regardless of adding '$expand=sessions($expand=segments)' to the request. In fact any value (even a single character) placed after .../communications/callRecords/ returns the error (e.g. .../communications/callRecords/1)

0 Votes 0 ·

Ok. Does the above URL works in POSTMAN/Microsoft Graph explorer as well? HTTP 400 is telling that the server cannot process the request because it is malformed or incorrect.

0 Votes 0 ·
Show more comments

0 Answers