question

LukasFriedrich-2366 avatar image
0 Votes"
LukasFriedrich-2366 asked Sumarigo-MSFT edited

ERR_TOO_MANY_REDIRECTS in the case of Azure CDN(http-to-https redirect rule)

Getting to many redirects after creating rule:
46512-image.png

I followed this post:
https://docs.microsoft.com/en-gb/azure/cdn/cdn-standard-rules-engine
found from this post:
https://medium.com/azure-architects/configuring-azure-cdn-http-https-redirection-2a9e4aab0a77

The UI seems to have changed... No longer have access to HTTP Large > Rules Engine through the CDN profile.
Now, the rules engine is a tab on the CDN endpoint itself, rather than the profile. I think the subscription tier causes the variance.

I created a storage acc, blob storage, enabled a static webpage, created a cdn endpoint (https://makesethmad.azureedge.net), custom domain (www.issethmad.com) pointed to the cdn endpoint successfully and HTTPS enabled through azure's provided SSL.

The goal is to make make issethmad.com and https://issethmad.com/ redirect to my correct site.

CDN endpoint with SSL enabled through Azure CDN HTTPS feature
Google Domain has cname record of www.issethmad.com that points to "https://makesethmad.azureedge.net"
DNS setting: subdomain forward from "issethmad.com" to https://makesethmad.azureedge.net

Note: https://makesethmad.azureedge.net was working with all the DNS settings. Issue flared when I added the rule, not to say my DNS settings are perfect :D


Thank you for taking time to read this!


azure-blob-storageazure-dnsazure-webapps-custom-domainsazure-static-web-apps
image.png (10.8 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

LukasFriedrich-2366 avatar image
0 Votes"
LukasFriedrich-2366 answered Sumarigo-MSFT edited

Changed condition to Request protocol match condition

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.



@LukasFriedrich-2366 Glad to know that the issue is resolved. Thanks for the update! Kindly do let us know if you need further assistance.

0 Votes 0 ·