question

MirajMohajireen-5874 avatar image
0 Votes"
MirajMohajireen-5874 asked MirajMohajireen-5874 commented

Configuring a dTPM chip on Raspberry pi running Windows IoT Core

I am a beginner on all IoT related things. Hence, sorry in advance for all the experts I might annoy, and thanks for your patience.

I provisioned my rpi3 to azure with a simulated TPM. But now I've purchased a TPM SLM 9670 chip and attached it to the pi.
The goal is to use this TPM to provision the pi to Azure. So I followed the steps here



To break down my approach w.r.t link I was following,
Step 1 done.
Step 2,3 skipped as I'm using an rp3.
Step 4: "Based on your discrete TPM module of choice, identify its matching ACPI table here.".. I have no idea how to find a matching ACPI. So I did trial and error with every ACPITABL.dat file in the given repo (Step 5). Note that I already had a ACPITABL.dat in the system32 folder. I took a back up of that before replacing it with the ACPITABL.dat file from the repo.
Step 6 Done
Step 7 Done
Step 8 When I run t2t.exe -cap ERROR(0x8028400f): Tbsi_GetDeviceInfo() failed. (This happened for all the ACPITABL.dat files I copy pasted in Step 5). Replacing the original ACPITABL.dat file that was in the sys32 folder and running the t2t.exe -cap command results in the following.

TBS detected 2.0 simulated TPM (sTPM).
Capabilities:
PT_FIXED:
TPM_PT_FAMILY_INDICATOR = '2.0

Any help is greatly appreciated


windows-iot-10core
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The error code 0x8028400F means the TPM cannot be found.TPM SLM 9670 chip uses SPI interface to connect to the device. Could you please tell me if you checked that you connected the TPM to SPI CS0 or CS1?Please refer to the pin map.


1 Vote 1 ·

Got the issue solved, and now my dTPM is recognized by the Pi. I didn't know about the the pin map when I asked this question and didn't know how to determine whether it was SPI CS0 or CS1. I did a lot of trial and error and found out it was SPI CS1 that's the correct one. But now I understand why it's SP1 after checking the pin map reference you gave. Thanks a lot. Learning is fun.

0 Votes 0 ·

0 Answers