question

AnandT-6561 avatar image
0 Votes"
AnandT-6561 asked ·

SharePoint On-Premise Pages unresponsive while connecting via WAP

I have Sharepoint 2019 on-premise configured withe kerberos Constrained delegation, if i login using the Windows authentication everything working fine,

i have the WAP and ADFS(Non-claims aware Relying party) and i authenticatin through ADFS via WAP the sharepoint sites are unresponsive, but i am able to login and the pages are not rendering fully. it strucks .

what needs to do to make it work with ADFS Non-Claims Aware relying party via WAP.

 Set-WebApplicationProxyApplication -BackendServerAuthenticationSpn 'HTTP/sharepoint2019.mydomain.com' -BackendServerUrl 'https://sharepoint2019.mydomain.com/' -ExternalCertificateThumbprint 'C738403CDD99A7B423CCBA1A73ED588D78YE839' -EnableHTTPRedirect:$true -ExternalUrl 'https://sharepoint2019.mydomain.com/' -Name 'Sharepoint2019' -ID '152031a0-eda5-19bf-ea88-e0e5910de73f'


Tried Adding the below registry entry as well but still not working,

 Set-ItemProperty 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp\' -Name EnableDefaultHTTP2 -Value 0


Getting More 500 Internal Server Error

office-sharepoint-server-administrationadfs
· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

You'll have to share a bit more about what you've done on the WAP. Maybe you can share some scripts you have used, or a screen shot of your WAP console?

0 Votes 0 ·

added the script from the WAP

0 Votes 0 ·
AnandT-6561 avatar image
0 Votes"
AnandT-6561 answered ·

I have found that the Kerberos Constrained Delegation should be on the Sharepoint Site Application User account, and that need to be mapped to the WAP Host on the Domain Controller.

now it is working fine

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JerryXu-MSFT avatar image
0 Votes"
JerryXu-MSFT answered ·

Hi, @AnandT-6561 ,

For your scenario, I would suggest you to open a ticket about this issue. And you can check the ULS log and event viewer for more detailed information about this unexpected behavior.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

If i access the sharepoint server directly it is working fine, but if i access the sharepoint site through WAP and ADFS the pages are not rendering and unresponsive.

0 Votes 0 ·