question

Marcus-9726 avatar image
0 Votes"
Marcus-9726 asked JoshuaEss-3750 published

SSMS Object Explorer Showing Blue Question Mark for SQL Server & SQL Server Agent - SQL FCI Setup

I have a two nodes SQL failover cluster instance setup. When I try to connect to SQL FCI in SSMS using sa on ACTIVE node, it shows the blue icon but if I access the instance from PASSIVE node, it displayed a green icon perfectly. I have simulated a test lab environment according to my production and it behave the same as production. The configuration and scenarios are as below:

  • SQL FCI: SQL 2019 Eval

  • OS Version: W2019 Standard

  • iSCSI shared disks attached to both nodes

  • TESTLAB\SQLADMIN1 (Domain admin account that used to perform the installation and configuration) - Local administrator of both nodes and also the domain administrator

  • TESTLAB\SQLSERVICE (Domain user account that being used as service account as well as SQL logins) - Local administrator of both nodes

  • sa account enabled

  • No Firewall in between and Windows Defender Firewall has been turned off on both nodes

Scenario 1 (Working fine):
Login to ACTIVE/PASSIVE node with domain administrator account (TESTLAB\SQLADMIN1) and launch SSMS, tried with Windows authentication and SQL authentication (using sa account). Both account displayed green icon on SQL server and SQL Agent.

50800-5.jpg


Scenario 2 (Question mark appear):
Login to ACTIVE node with domain user account (TESTLAB\SQLSERVICE) and launch SSMS, tried with Windows authentication and SQL authentication (using sa account). Both accounts displayed blue question mark on SQL server and SQL agent. If I login to ACTIVE node using Domain admin account, no issue occur.
50708-image.png


Scenario 3 (Working fine):
Login to PASSIVE node with domain user account (TESTLAB\SQLSERVICE) and admin account (TESTLAB\SQLADMIN) and launch SSMS. Both Windows authentication and SQL authentication used, green icon appeared on SQL server and SQL agent.


My issue is similar to below thread but there's no resolution:
https://social.msdn.microsoft.com/Forums/en-US/d569112f-dcea-4849-aa60-5abaeaa18e50/database-instance-on-object-explorer-showing-question-mark-on-cluster-host-server?forum=sqltools

I have manually added my SQL service account to WMI management to allow remote enabled but still having the same issue.

sql-server-generalwindows-server-clustering
5.jpg (21.4 KiB)
image.png (9.2 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
The problem seems to occur only when logging in to the ACTIVE node locally using the TESTLAB\SQLSERVICE account and strating SSMS.
What permissions does The account TESTLAB\SQLSERVICE have in the SQL Server instance(sysadmin?).
In Scenario 2, will there be any difference when SSMS is launched as an administrator (run as administrator)?

0 Votes 0 ·

Hi Criszhan,

The TESTLAB\SQLSERVICE account is a local administrator and sysadmin also in SQL Server instance. Even if I used 'sa' it will behave the same as TESTLAB\SQLSERVICE. If I launch the SSMS as administrator it showed a green icon which is normal indication. I'm not sure why it behave like this as the account I used to login was local administrator.

0 Votes 0 ·

Hi,
Have you tried another domain user account.

0 Votes 0 ·
Show more comments
pituach avatar image
0 Votes"
pituach answered

Good day,

Please check if this post provide you all the information

https://ariely.info/Blog/tabid/83/EntryId/282/SSMS-display-the-status-of-services-by-using-different-icons.aspx

In general, white question mark on blue circle icon means Status Unknown and in the post you can find some optionally solutions.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Marcus-9726 avatar image
0 Votes"
Marcus-9726 answered

Hi Pituach,

Seems like running SSMS as administrator solved the issue. But why I have to run it as administrator since this current logon user is already a local administrator? Meanwhile, If I logon using domain administrator I don't have to run SSMS as administrator also.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JoshuaEss-3750 avatar image
0 Votes"
JoshuaEss-3750 answered JoshuaEss-3750 published

I ran into a similar problem - what fixed it for me was changing the @@servername attribute (from its default: 'INST-INSTALL-SQ') to match the server's hostname. See here: https://blog.sqlauthority.com/2015/07/13/sql-server-how-to-change-server-name/



In my case, this is a standalone server, not part of a cluster, so YMMV.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.