question

jmaurier avatar image
0 Votes"
jmaurier asked ·

Problem webapp Wordpress on Linux Azure

Hello there,
I'm facing an issue when i try to deploy Word press on Linux in Azure in a new ressource group. i've tried in France Central and North Europe.
The deployment fail with an error on the Webapp and the following details : https://pastebin.com/nmfZHd8b

Edit : i just found my problem :) It was du to the portal app. I've tried in standard web browser and it worked :)

azure-webapps
· 1
10 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@JulienMAURIER-5459, It appears that after switching the browser, you were able to resolve the issue. could you please elaborate more on this 'it was du to the portal app', we can highlight the possible solution for benefiting the community with a similar issue. Thanks!

0 Votes 0 ·

1 Answer

ajkuma-MSFT avatar image
1 Vote"
ajkuma-MSFT answered ·

@JulienMAURIER-5459, Welcome to Microsoft Q&A! Thanks for posting the question and sharing the solution that worked for you.

For benefiting the community, summarizing the scenario:

Scenario: Unable to deploy Wordpress on Linux App Service WebApp.
Error: The deployment shows the following error.


 {
   "code": "DeploymentFailed",
   "message": "At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.",
   "details": [
     {
       "code": "Conflict",
       "message": "{\r\n  \"Code\": \"Conflict\",\r\n  \"Message\": \"Parameter with name DATABASE_HOST already exists.\",\r\n  \"Target\": null,\r\n  \"Details\": [\r\n    {\r\n      \"Message\": \"Parameter with name DATABASE_HOST already exists.\"\r\n    },\r\n    {\r\n      \"Code\": \"Conflict\"\r\n    },\r\n    {\r\n      \"ErrorEntity\": {\r\n        \"ExtendedCode\": \"01013\",\r\n        \"MessageTemplate\": \"Parameter with name {0} already exists.\",\r\n        \"Parameters\": [\r\n          \"DATABASE_HOST\"\r\n        ],\r\n        \"Code\": \"Conflict\",\r\n        \"Message\": \"Parameter with name DATABASE_HOST already exists.\"\r\n      }\r\n    }\r\n  ],\r\n  \"Innererror\": null\r\n}"
     }
   ]
 }



Typically, the error message may occur if you're using the database host name which already exists. In this case, use a different host/parameter name so there is no name conflict.


Solution that helped- "It was du to the portal app. I've tried in standard web browser and it worked :) " (Copied from the "Edit" on the post).

10 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.