question

TanishqSingh-0833 avatar image
0 Votes"
TanishqSingh-0833 asked ·

IOT hub messages not being received in Azure Stream Analytics input

Hi,

I'm trying to send simulated smart meter JSON data to IOT hub. This data is needed as input for a stream analytics job. I can see that the messages are being sent to IOT hub but on sampling stream analytics input I get the following notification-

"No events found for 'smartinput'.
Start time: Sunday, April 12, 2020, 5:19:28 PM
End time: Monday, April 13, 2020, 5:19:28 PM
Last time arrival: Monday, September 23, 2019, 5:34:37 PM
Diagnostics: While sampling data, no data was received from '2' partitions."

Any help is appreciated. Thanks.

not-supported
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SandervandeVelde42 avatar image
1 Vote"
SandervandeVelde42 answered ·

It seems your incoming device telemetry is not arriving at the Azure Stream Analytics input.

There can be several reasons for this.

Here are some steps to check the connectivity:

  1. Please check if the telemetry is actually arriving at the IoT Hub

  2. Check if the telemetry provided us in the correct JSON format

  3. Check if the IoTHub routing is passing all data to the default endpoint (eg. no disabled fallback endpoint)

  4. Give the IoTHub an extra consumer group to prevent other resources from 'hijacking' messages (under IoTHub | Settings | Built-in endpoints)

  5. Check the Stream Analytics input (is it connected to the right IoT Hub with the right consumer group) and after submitting, check the automatic connectivity test.

If this does not work, please first output to an Event hub and connect that Event hub as an input for your Stream Analytics Job. You get more insights from that event hub.

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

karishmatiwari-msft avatar image
1 Vote"
karishmatiwari-msft answered ·

The IOT forum has not yet moved to Q&A platform. Please post IOT questions on MSDN forum here


Please refer to this thread for updates on the forum movement from MSDN to Q&A: Microsoft Q&A to replace MSDN community platform!


· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.