question

DaanPoleij-1444 avatar image
0 Votes"
DaanPoleij-1444 asked ·

Question about a thread already closed, unsolved. (GPO User policy not applying when using FSLogix Profile Containers)

Hi all,

I've been having an issue quite for some time and it's the exact same issue as displayed in the link im dropping in the comments, I can't post it in the body because then I get the familiar "WAF v2 has determined your request exceeded the normal web request and has blocked your request."

Someone else still having the issue?

azure-virtual-desktopwindows-server-fslogix
· 5
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This was the link I was mentioning, a lot of people seem to be having the same issue. I have tried everything recommended by Microsoft in that thread but it remains unsolved.


https://social.msdn.microsoft.com/Forums/en-US/14bed90e-67a2-4100-a282-6c7b57b68fc9/gpo-user-policy-not-applied-when-using-fslogix-profile-container-used?forum=FSLogix

0 Votes 0 ·

@DaanPoleij-1444 Please do mention the server version you are using, the known working workaround for the problem is to have following two settings on your servers :

FSLogix registry key:
DWORD GroupPolicyState = 0 under HKLM\SOFTWARE\FSLogix\Profiles\

Computer Policy GPO:
Computer Config | Admin Templates | System | Group Policy | Enable Group Policy caching for servers

0 Votes 0 ·

@DaanPoleij-1444 Let us know if you got a chance to check the above workaround and see if it works for you.

0 Votes 0 ·

Excuse me for the late answer, we got this fixed.

0 Votes 0 ·
Show more comments
vipulsparsh-MSFT avatar image
0 Votes"
vipulsparsh-MSFT answered ·

@DaanPoleij-1444 Please do mention the server version you are using, the known working workaround for the problem is to have following two settings on your servers :

FSLogix registry key:
DWORD GroupPolicyState = 0 under HKLM\SOFTWARE\FSLogix\Profiles\

Computer Policy GPO:
Computer Config | Admin Templates | System | Group Policy | Enable Group Policy caching for servers

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

FranklinMuthuswamy-3295 avatar image
0 Votes"
FranklinMuthuswamy-3295 answered ·

I had this working in either of the following two ways: - Only requirement was that the FSlogix had to be installed with domain admin credentials on the VMs:

  1. Registry entries on the VMs in host pool
    HKLM:\SOFTWARE\FSLogix\Profiles (if a path called Profiles is not available in FSLogix, create it)
    DWORD : Key: Enabled value: 1
    Multistring: Key: VHDLocations value: "\\path of the fileshare server or azure storage fileshare"

  2. Group policy object in the PDC (to apply to the VDIs mapped as computers - I have my WVD VMs in a separate OU to which I link this GPO)

Computer Configration>>Policies>>Administrative Templates>>FSLogix>>Profile Containers>>
'Set Outlook cached mode on successful container attach" Enabled
'Enabled' Enabled
'VHD Location' Enabled (give the path of the fileshare)
'Delete local profile whenn FSLogix Profile should apply' Enabled

Computer Configration>>Policies>>Administrative Templates>>FSLogix>>Profile Containers>> Container and Directory Naming
'Virtual disk type' Enabled
'Swap directory name components' Enabled

The best approach would be through GPO because that pushed the policy on one go to all the VMs in the pool.


·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.