question

GlennMaxwell-2309 avatar image
0 Votes"
GlennMaxwell-2309 asked KyleXu-MSFT commented

Room Mailbox Restriction

Hi All

I have a room mailbox by name room1@contoso.com, and i have a user user1@contoso.com. I have requirement to set restriction on this room mailbox i.e Only user1@contoso.com should be able to book this room and no other user other than user1 should be able to book this room. Experts guide me with the syntax.

office-exchange-server-administrationoffice-exchange-online-itprooffice-online-server-generaloffice-online-server-exchange
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@GlennMaxwell-2309
Any update about this thread now?
If the suggestion below helps, please be free to mark it as an answer for helping more people.

0 Votes 0 ·
AndyDavid avatar image
0 Votes"
AndyDavid answered AndyDavid edited
 Set-CalendarProcessing  room1@contoso.com  -AllBookInPolicy $false -BookInPolicy "user1@contoso.com" 

https://docs.microsoft.com/en-us/powershell/module/exchange/set-calendarprocessing?view=exchange-ps

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GlennMaxwell-2309 avatar image
0 Votes"
GlennMaxwell-2309 answered AndyDavid rolled back

Thanks, if i need to revert back the settings should i use the below syntax.
Set-CalendarProcessing room1@contoso.com -AllBookInPolicy $true -BookInPolicy $true

If i need to add multiple users will the below syntax work
Set-CalendarProcessing room1@contoso.com -AllBookInPolicy $false -BookInPolicy "user2@contoso.com","user3@contoso.com"

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

If you need to set things back, run:

 Set-CalendarProcessing room1@contoso.com -AllBookInPolicy $true -BookInPolicy $null

-BookinPolicy represents the recipient, not true or false.
Also, no <> in the command. I removed that


to add multiple:

 Set-CalendarProcessing room1@contoso.com -AllBookInPolicy $false -BookInPolicy "user2@contoso.com","user3@contoso.com"

From the doc:
Set-CalendarProcessing -Identity "Car 53" -BookInPolicy "ayla@contoso.com","tony@contoso.com" -AllBookInPolicy $false





0 Votes 0 ·