question

ravikumar-1532 avatar image
0 Votes"
ravikumar-1532 asked ravikumar-1532 commented

how to publish excel VSTO for different frameworks

I am very new to c# , I have now created my first excel VSTO which calculates some custom values for the data columns in the active sheet. Now I have to publish the same and get it installed in 5 to 6 PC , the VSTO I have created is having .Netframework 4.8 and tested in Microsoft excel for Microsoft 365 MSO 32-bit.

but the target systems are having excel 2013,2010 & 2007 and lower version of framework.

how to publish this VSTO which can support these requirements ?please help me..

dotnet-csharpvs-generaloffice-vsto-com-dev
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

DylanZhu-MSFT avatar image
0 Votes"
DylanZhu-MSFT answered ravikumar-1532 commented

Hi ravikumar-1532,

You don't need to change target system, the VSTO with .NetFramework 4.8 can be backward compatible. The related document: Run solutions in different versions of Microsoft Office

Best Regards,
Dylan


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @DylanZhu-MSFT thank you for your response ...when i tried to install to install in other it is redirecting me to download .net4.8 framework forcibly otherwise it is not getting installed ..how to solve this..

0 Votes 0 ·

Hi @ravikumar-1532 , thank you for your feedback. The specified framework is required on the target system.
58056-image.png
Or, maybe you need to change framework of your VSTO, then re-publish to different system.

1 Vote 1 ·
image.png (21.8 KiB)

hi @DylanZhu-MSFT thank you so much now i found what was the problem as framework itself wasn't available in the target system , it is now working , thank you so much for your help

0 Votes 0 ·