question

CromwellMontenegro-5972 avatar image
0 Votes"
CromwellMontenegro-5972 asked ·

Unable to RDP to VMs

What are the common cause in unable to remote desktop to Azure VMs? I already have RDP ports enable as well successfully did a network test.

azure-virtual-machines
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

msrini-MSFT avatar image
1 Vote"
msrini-MSFT answered ·

Hi,

You can first check if there are IP connectivity to the VM. Try to telent or try any layer 4 connectivity test to your VM's Public IP on port 3389.

If that is closed, then you need to check if you have allowed port 3389 in the Inbound rule of your VM's NSG.

You can also follow this troubleshooting guide: https://docs.microsoft.com/en-us/azure/virtual-machines/troubleshooting/troubleshoot-rdp-connection

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ArwindYadav-7228 avatar image
1 Vote"
ArwindYadav-7228 answered ·

If you have changed the default RDP port then run following Power Shell Script.

netsh advfirewall firewall add rule name="Open RDP Port " dir=in action=allow protocol=TCP localport=

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RnD0102 avatar image
0 Votes"
RnD0102 answered ·

maybe DNS issues,please check your dns. or try to use public-ip

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

bedge avatar image
0 Votes"
bedge answered ·
  • Check if your machine that will connect to the Azure VM is allowed for connecting outbound to 3389.

  • Check if port 3389 is being blocked on the NIC's NSG before checking the NSG on the subnet level.

  • Try restarting the virtual machine.

  • Try redelopying the VM to another host.


· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BrandenNaidoo avatar image
0 Votes"
BrandenNaidoo answered ·

Check you rdp version on your workstation matches your VM version and that NLA is enabled.

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.