question

JimBosley-3340 avatar image
0 Votes"
JimBosley-3340 asked ·

Can't get sound to work with Teams in Ubuntu 20.04

In another thread, I posted:

Critical Error: No sound (Ubuntu 20.04 LTS)
In several Teams meetings, I log into the meeting and can see my conferee partners, but I can't get sound, or they can't get sound. A total fail. I'm doing this in Ubuntu. I make sure that my devices are all set properly, I go to the "Sound" app in Ubuntu and set the Sound settings correctly, to no avail. Today, we were able to use phones to connect for a one-on-one call but I've missed being able to participate in critical meetings.
There's a solution posted on the web that involves turning off the new meeting experience. That won't work: I don't have that option (I'm using the free version, installed with sudo apt install ./teams_1.3.00.30857_amd64.deb).
Given that Teams cannot reliably be used, my firm is avoiding any Teams meetings, advising clients "Teams doesn't appear to be reliable, can we switch to google-meet or Zoom?". But some firms are hard-coded for Teams, so I'd like to get this fixed.
Any advice
?
The normal Microsoft advice to "Check to ensure your drivers are up to date, if they are, and the problem persists, reinstall Windows 10" is obviously not gonna work here...

Shyamal Debnath replied and asked some questions, and suggested that I cross post here. Also, suggested I use the tag linux-teams. Done. So here's my reply to Shyamal:

Shayamal, thanks for a constructive response. So I'm using Ubuntu, and my understanding is that the only reliable way to use Teams on Ubuntu is to use the browser-based solution. That is, IIRC I read somewhere that the Linux/Ubuntu app doesn't work. [NOTE: See thread in this forum "Can't join meetings as guest from Linux Teams app's newest version any longer"]. When I click on a meeting link to open up Teams, and use the Teams linux app, the meeting apparently isn't recognized. So I'm using the web-based solution.


Ubuntu's sound setup is neither as simple nor as reliable as Win 10. I have a Jabra Evolve 75 (BT, noise cancelling) and an Jabra Engage 75 (BT, DECT, no noise cancelling) and once I'm in the meeting and can see the other folks, apparently nothing I do gets either of those devices working. When I boot I open the Ubuntu "Sound" setting window and select Jabra 370 (mic and analog out, respectively) for sound. The Jabra 370 is the USB dongle that has the BT connection in it, and it works with my Evolve 75 headset (which has a mike).

When I open my free Teams, a popup windows opens asking if I want to open a program (xgd??.open - can't recall exactly) and after I do this the web dialog offers connection via the web interface (as I said, the app just doesn't work). The picture pops up fine. But nothing I do (changing settings in Ubuntu's "Sound", changing settings in MS Teams, restarting the application, ... nothing allows me to hear or fellow meeting attendees to hear me.

Other apps (including browser based solutions like YouTube, and other conferencing programs like Zoom, Google Meet, Skype, webex all seem to work fine). It's just that when I log into a teams meeting I have no confidence that it will be useable.

I'll cross-post as suggested. Once again thanks for something constructive.

office-teams-linux-itpro
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered ·

Hi @JimBosley-3340

Does anyone else have the same issue in your organization?

Someone in the past had issues with the mic and, by reconfiguring the pulse audio, it got solved.

Microphone for teams on Linux not working - Microsoft Q&A


If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 3 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @JimBosley-3340

Is there any progress on this issue?

0 Votes 0 ·

Hi @JimBosley-3340

Any update?

0 Votes 0 ·

Absolutely! This has become a painful experience! Almost every meeting I have quit teams and then launch again just to get sound. Very irritating to say the least especially when there are important meetings.

0 Votes 0 ·
MikeA-1870 avatar image
0 Votes"
MikeA-1870 answered ·

A coworker of mine just experienced this same problem. The issue he encountered was actually a misleading result from Ubuntu.

Prior to Microsoft releasing their official Linux support that comes with a deb file, someone ported the browser experience into an Electron app as a Snap package. Ubuntu as of 20.04 is now redirecting many apt commands to use snap because they're trying to push that as a solution. So if you hadn't manually installed the deb file, running just sudo apt install teams would have installed the snap package version.
This snap package version is also very old and unmaintained. It seems that the snap package is no longer fully compatible with the Teams servers, so it causes all kinds of issues with desktop sharing and audio.

I suspect this is what happened: at some point before you installed the deb file, the snap was installed. This worked for quite a while and was similar enough to the deb version that it wouldn't have really been noticeable. You then ran the deb installer at some point and it attempted to install the new deb file. That will add a new PPA for microsoft teams, and attempt to install the teams package provided from it. However it appears to the apt system that you already have teams installed and it may or may not be properly reporting that the one from the microsoft PPA is newer relative to the snap (my coworker's system thought the very old snap was still newer).

To solve this (this worked for him):

  • Uninstall the snap version (all) sudo snap remove teams teams-insider teams-for-linux

  • Reboot your system

  • Make sure you have the latest information about PPAs sudo apt update

  • Re-download the latest deb file (just to be sure) from here: https://www.microsoft.com/en-us/microsoft-teams/download-app#desktopAppDownloadregion

  • Manually run the deb install using the deb file itself (must be full file name for this) sudo apt install ./teams_1.4.00.4855_amd64.deb

Now try running Teams again and see if it works. I've been able to use the official deb successfully with my Jabra Engage 75 without issue on Ubuntu once I had it properly installed. You'll definitely have to manually setup your audio device in Teams though, it doesn't detect defaults at all, and the softphone buttons on the headset and base won't work (start & end).


·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.