question

PatricSten avatar image
0 Votes"
PatricSten asked ·

hostingEnvironment parameter

Hi!

Trying to deploy Wordpress from marketplace through a ARM-Template,


In the template there is a parameter hostingEnvironment :

   },
         "hostingEnvironment": {
             "value": ""
         },

its required and im not able to leave it blank as some people suggest.
What is expected here?


azure-webapps
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

PatricSten avatar image
0 Votes"
PatricSten answered ·

"Windows" i guess?

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ryanchill avatar image
0 Votes"
ryanchill answered ·

Assuming you used https://ms.portal.azure.com/#create/WordPress.WordPress as a template, it's using https://docs.microsoft.com/en-us/azure/templates/microsoft.web/2018-02-01/sites template, I do realize that hostingEnvironment isn't documented. But I'm fairly certain hostingEnvironment references an App Service Environemt which is basically an isolated App Service. You shouldn't need that as long as serverFarmId (your app service plan) is set.


·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.