question

LuuNgocManh-0888 avatar image
3 Votes"
LuuNgocManh-0888 asked Andreas-2337 commented

[UWP] Problem when restart app on kiosk mode

We are developing a POS application which will be setup at our stores.
This app is an UWP application which run on Windows 10 IOT LTSC - Kisk Mode and we decided to deploy using side-loading.

In order to improve the update process, we have try using this library to implement the application update feature
https://github.com/Dwrandaz/AutoUpdateComponent

On desktop mode, It works well with out any problem. After update process, the application will be restarted and the new version will be loaded.
But on kiosk mode, sometimes after updated, the application can't restart:

  • After update process, the application try to restart but it stuck on blue windows with loading spinner.

  • We also try waiting for a few hours but nothing change

  • If we try force restart device (use power off button) then after logged on kiosk mode, the application will be loaded with new version.


  • We have been tested the update process for about 20 times and just 1 times this problem occurred.

Beside, this problem also occurred when we implement restart button using method App.Current.Exit()
so we think that there is no problem with update process, it is problem of restart function when run on Kiosk mode.

If anyone know about this problem, please help us.




windows-uwp
· 9
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello friend, Have you confirmed if there is some resource not released after update and restart the app?


Best Regards, Michael


0 Votes 0 ·

What kind of resource which can cause this problem.
I have process to open file for logging only.

0 Votes 0 ·

Sorry, i can not reproduce the issue. Some resources need you to use dispose method to release the handle and memory. So it is hard to say what could cause the issue. You may try to check what resources were used in your app, such as media play, or network connection, and so on.

0 Votes 0 ·

Hi, does the suggestions help? Can you solve your issue?

0 Votes 0 ·

I have tried keeping the open file connection and update version but the problem didn't occur.
I think it isn't the root cause but still try to reproduce by other ways (TCP connection)

0 Votes 0 ·

Have you tried to check the resources mentioned above?

0 Votes 0 ·

Hi @LuuNgocManh-0888 are you still working on this? Have you been able to make it work? I have experienced the same problem. I posted an answer to what now seems to be working for me here: intune-kiosk-blue-screen-spinner-after-uwp-app-res.html

It would be interesting to hear if this works for you as well or if you have done something different?

Also it would be very interesting to get som feedback from microsoft that could explain the behaviour.


0 Votes 0 ·

thanks for your reply.
But I think that install kiosk app directly under admin account is not a solution. The first when the app was installed under admin account, there is a problem which I had. When I updated the app in kiosk mode, but the app in admin account still be previous version. I think they are not sync between the main app and the app in kiosk mode due to windows still create a new user for kiosk mode instead of we install kiosk mode under admin account. And sometime, it also cached the previous version and I can't update it.
The best way is install kiosk into the second local account to prevent this problem.
Beside that, it also had blue screen problem too.

0 Votes 0 ·

I only install the app in the admin acount the first time. Before I create the Kiosk account. Then for the updates I install them from within the app in Kiosk mode. For me it is a difference if I create the app as a local account first and then make it a Kiosk account (if I do it this way it wont work).
If I create the Kiosk account directly as a assigned access acount (no local acount that I convert to assigned access), then it works for me. So far at least. I think it is very strange that there is difference between the accounts depending on how I create them. For the updates then I agree with you that you must update from the Kiosk account otherwise you will only update the admin app.

I still don´t know why this works for me and I am not very confident about the sollution. My feeling is that there is some sort of malfunction in the microsoft assigned access acount. And in my windows version this just happens to work when I do like I do. But I don´t know why.

0 Votes 0 ·

0 Answers