question

User47 avatar image
0 Votes"
User47 asked ·

Outlook 2019 search japanese characters incorrect results

Hi,

I'm having an issue with Outlook (Microsoft Office Professional Plus 2019) and searching japanese characters.

For example, if I search the word "あいおい", it will give me results including all messages containing the individual characters "あ", "い" and "お" somewhere in their text.
65866-image.png

If I do the same search in OWA, it will only return the messages containing the full word, which is what I would expect :
65825-image.png

Any idea how to have the same behaviour in Office ? I already installed the japanese language and proofing for Office, but that didn't help.

Thanks.

office-outlook-itpro
image.png (6.5 KiB)
image.png (11.2 KiB)
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JadeLiang-MSFT avatar image
0 Votes"
JadeLiang-MSFT answered ·

Hi @User47 ,
Welcome to our forum.
Did this issue only occur when you search the Japanese characters? Due to I know little about Japanese, If it's possible, please post your whole test Japanese characters and strings here, so that I could perform more same tests on my environment.
I just have tested with English characters on my Outlook 2019 and found it would display the similar effects with yours when I search with space characters(such as "test a"), then we could search it via type " "test a" "(add double quotes) to display these results with "test a "string only. So it's suggested to search your character with the double quotes to check if the issue has any difference.

If the issue still exists, due to the instant search in Outlook is based on windows search, and it may not be able to work normally when the windows search index is corrupted, it's suggested to troubleshoot your windows search via rebuild the search index(control panel>Indexing Options>Advanced>Advanced Options>Rebuild)

If that's invalid, as I know, the corrupted Outlook profile may also cause it, please try to create a new Outlook profile and re-add your account to test.(Control Panel>Mail>Show Profiles>Add)

Hope that would be helpful to you.


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 8 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Thanks for the reply.

So here's the contents of the correct message (which I want the search to return):
"あいおい"
And an example of incorrect message, which contains the same characters but not in the same word:
"あたま
いちご
おてら"

I tried rebuilding the search index, but that doesn't seem to help.

I also tried re-creating the profile and that didn't work either.
However, one thing that I haven't mentioned yet is that I usually disable Cached Exchange Mode. And that does seem to have an impact. I tried re-creating the profile but with Cached Exchange Mode enabled, and now the search seems to work as expected.

Actually it's not the first time I have issues with Cached Exchange Mode. But I can't re-enable it, some people here have mailboxes of over 20GB...
Would you know if there's a way to make the search work correctly with Cached Exchange Mode ?

Thanks.

0 Votes 0 ·

Hi @User47,
Thanks for your update, I have tested those Japanese character with cached exchange mode in my Outlook 2019, but it could work normally there.

I tried re-creating the profile but with Cached Exchange Mode enabled, and now the search seems to work as expected.

Did you mean that you could work normally in online mode? As I know, the instant search in exchange mode may depend on windows search, so I think the issue may be related to your corrupted windows search. I have researched a lot about it and found a related article to troubleshoot issue on windows search, it's suggested to check if it could work for you.

Hope your issue would be resolved soon.

0 Votes 0 ·

Hi,

68085-image.png
What I'm saying is:
If I check the "Use Cached Exchange Mode" box, the search works fine (searching the whole word "あいおい").
If I uncheck the "Use Cached Exchange Mode" box, the search doesn't work correctly (searching individual characters "あ", "い" and "お" separately).

I tried the suggested solutions in your article, but unfortunately that didn't help.

Thanks.


0 Votes 0 ·
image.png (1.8 KiB)

Hi @User47,
Thanks for your update and sorry for misunderstanding. Considering the issue occurred on online mode, it's suggested to search on your owa to check if the issue has any difference, if the issue could be reproduced there, it may be related to your account itself instead of Outlook client, the troubleshooting method in outlook may not affect it, it's suggested to contact your admin to check your mailbox.

By the way, if you could work normally in cached exchange mode and just worried about the mailbox size, we actually work in cached exchange mode with cached part of your mailbox instead of all items(such as recent 3 months or even 3 days) via slide the time zone in account settings.

Hope that would be helpful to you.

0 Votes 0 ·

Hi,

Thanks again for your time.

As I said in my initial message, I can't reproduce the problem in OWA. The search works fine there.

I guess I'll have no choice but to activate cached exchange mode then. Maybe, as you suggest, only for a limited period.

0 Votes 0 ·

Hi @User47 ,

Sorry for delay and I'm still researching for your issue. as you mentioned, we could choose to use cached mode as a workaround temporarily.

Also, if you are still researching for this issue, we could perform more tests to further analyze it:

Did the issue only occurred on any specific users and specifc clients? Could the issue be reproduced if you log in your account on other Outlook client?
In the point of Outlook client, what's the specific version of your Outlook client(File>Office account>About Outlook)?

If your issue has any update, please feel free to post back.

0 Votes 0 ·

Hi,

I haven't found that it was linked to specific users or clients. Users notified me of this issue, and I was able to reproduce it with my own machine and user.
Version: Microsoft Outlook 2019 MSO (16.0.10348.20020) 64-bit.

Thanks.

0 Votes 0 ·

Hi @User47,
Are you and the user experiencing the problem all working with same version of Outlook client?

If so, I noticed that you are using an old version of Outlook 2019, considering the searching could work normally in my Outlook 2019 version 2101(Build 13628.20448) , it's suggested to update your Outlook to check if the issue has any difference.
If you are working with office 2019 C2R, we could actually find update option like below and update office directly via click Update Now.
71515-snipaste-2021-02-24-16-36-30.jpg

Hope your issue would be resolved soon.

0 Votes 0 ·
User47 avatar image
0 Votes"
User47 answered ·

Hi,

I updated to version 1808 (Build 10371.20060), and it is now telling me that my version is up to date.
But that didn't solve the issue.

By the way, if I do an "Advanced Find", it works as expected:
72122-image.png


image.png (22.6 KiB)
· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @User47,
Thanks for your update. As I know, the working principle of advanced find is actually different to Instant search in Outlook.
I have tried to perform same test on my Outlook 2019 version 1808(Build 10371.20060), but the Instant searching still could work normally there.
In order to further confirm if your issue is related to your account, if it's possible, could you please try to test on other account that is outside your organization? if the issue still exists there, it may be more related to your client, otherwise, I'm afraid it may be more related to your accounts themselves.
If your issue has any update, please feel free to post back.

0 Votes 0 ·