question

DavidGaulke-9508 avatar image
1 Vote"
DavidGaulke-9508 asked GagikKyurkchyan-1874 published

unable to add deployment slot in portal

When I attempt to add a deployment slot to a function app, I get this error:

 Failed to create slot 'stage': Required parameter AccessKey is missing.

Any ideas on what would cause this? I don't see any method of providing an access key from the add slot screen.


azure-functions
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This needs to be looked at from the configuration end of the function app. I will be working with @DavidGaulke-9508 offline and will update this thread.

0 Votes 0 ·

We are having the exact same problem. I've create a [stack overflow thread][1] describing the issue and the steps we took to try to resolve it. We've found temporary workaround, but it's extremely ugly and doesn't solve the problem


[1]: https://stackoverflow.com/questions/69166907/can-not-deploy-arm-template-of-azure-app-service-with-linux-that-has-mounted-sto

0 Votes 0 ·

We are having the exact same problem. I've create a [stack overflow thread][1] describing the issue and the steps we took to try to resolve it. We've found temporary workaround, but it's extremely ugly and doesn't solve the problem.


[1]: https://stackoverflow.com/questions/69166907/can-not-deploy-arm-template-of-azure-app-service-with-linux-that-has-mounted-sto

0 Votes 0 ·
MayankBargali-MSFT avatar image
0 Votes"
MayankBargali-MSFT answered MayankBargali-MSFT edited

If someone is facing a similar issue feel free to tag me or create a support ticket. This issue needs to be looked at from the configuration end of the function app. Look's like there can be some default configuration that might be removed for the function app.

In multiple instances the issue could be that the AccessKey on the storage account mounted to the app services was have flagged null at our end. You could update the value in resource explorer or redeploy without the storage mount and remount it after deployment.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MariusJacob-4813 avatar image
0 Votes"
MariusJacob-4813 answered

we are seeing the same issue with a Webapp for containers, when creating another deployment slot

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TobiasKleine-6483 avatar image
1 Vote"
TobiasKleine-6483 answered

We are also facing this issue. When trying to create a deployment slot, the creation fails with "Required parameter AccessKey is missing." from 1) Azure Portal, 2) Azure Portal Cloudshell and 3) local PS (using az cli tool).

Is there any status update?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JunYe-9754 avatar image
1 Vote"
JunYe-9754 answered

We had the exact same error when try to cloning into a new deployment slot.

Since AccessKey would normally only be used in Storage Account, we looked around and found

Settings -> Configuration -> Path mappings -> It was mounting a storage account (Currenly only avaliable in Linux App Service Plan)

Since we are not using this mount, we removed it and tried cloning again.

And it worked this time. But yes, I agree someone need to open up a ticket with MS to have this fixed permanantly.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.