question

BIDesarrollo-5150 avatar image
0 Votes"
BIDesarrollo-5150 asked ·

no input events or error messages

I have a workflow that has events from IoTHub as input, and displays the data in real time through an output in power bi. The problem is that suddenly the job stops receiving input data and therefore no longer shows data in Power BI, additionally there are no error or warning messages in the activity log, the only solution I have found is to stop the the job manually and restart it manually to restore service. As I mentioned earlier, there are no errors or warnings in the activity log, how can I diagnose the error?

azure-iot-hub
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @BIDesarrollo-5150 Just checking in if you have had a chance to see the previous response.
Please enable your preferred alert types on your Profile's Settings to get instant notifications on this thread's discussions. Here is how to subscribe to a notification.
If the response is helpful, please click "Accept Answer" and upvote it.

0 Votes 0 ·

1 Answer

SandervandeVelde42 avatar image
1 Vote"
SandervandeVelde42 answered ·

Hello @BIDesarrollo-5150 ,

it's hard to give a reason why the (Azure Stream Analytics) job stops outputting telemetry.

What I can think of is throttling. See the link for an elaborate explanation.

Or for some reason, the format of the message changes...

At least you could add some additional diagnostics. eg.:

  • Add a counter with the last input date time.

  • make a chart that represents the quality of the incoming flow

  • Output the same telemetry to a second output sink (eg. blob storage) so you can check those last moments when it occurs again



·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.