question

KatariaDipeshSITIITYFD-2935 avatar image
0 Votes"
KatariaDipeshSITIITYFD-2935 asked ·

Azure data factory trigger on event not working

Hi,

I am using Azure Data Factory V2 and want to set up a trigger based on a blob creation in a Gen2 ADLS. When I create the trigger, the paths are recognised as it shows me the blobs of interest, however when this gets published the trigger does not fire when a blob is created. I have checked the event against the Gen2 ADLS and I can see that the event is not being recognised in there. I have noticed this bug before. My location is West Europe.

72490-image.png


72581-image.png


72591-image.png


azure-data-factoryazure-data-lake-storage
image.png (57.7 KiB)
image.png (75.8 KiB)
image.png (30.4 KiB)
· 9
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@KatariaDipeshSITIITYFD-2935 Thanks for using Microsoft Q&A !!

Is trigger working with manual uploads of the blobs ? Also, have you tried using a Blob storage instead of ADLS to check if the triggers are working ?

0 Votes 0 ·

Hi,

The "trigger now" functionality does work. But it does not fire on blob creation.

I will try blob storage, but I have read on many threads that this only works with Gen 2 ADLS.

0 Votes 0 ·

@DipeshKataria-6394 @KatariaDipeshSITIITYFD-2935 No I am not talking about Trigger now. How are you uploading the blobs ? Is this through any automated process and have you tried creating the blob manually to see if the published event trigger gets fired ?

0 Votes 0 ·
Show more comments

0 Answers