question

GilFreund-8650 avatar image
0 Votes"
GilFreund-8650 asked ·

Powershell Get-NetAdapter breaks when vLANs exist

As current versions of Windows 10 no longer have integrated vLAN configuration, we moved to install Intel ProSet to configure our vLANs. This works relatively well in the GUI, but we have issues using powershell to manage the interfaces. Once the vLANs are configured, Get-NetAdapter no longed works:

 PS C:\WINDOWS\system32> Get-NetAdapter
    
 Name                      InterfaceDescription                    ifIndex Status       MacAddress             LinkSpeed
 ----                      --------------------                    ------- ------       ----------             ---------
 Ethernet 3                Fortinet SSL VPN Virtual Ethernet Ad...      26 Not Present  00-09-0F-AA-00-01          0 bps
 Ethernet 2                Fortinet Virtual Ethernet Adapter (N...      24 Disconnected 00-09-0F-FE-00-01       100 Mbps
 Ethernet                  Intel(R) 82579LM Gigabit Network Con...      14 Disconnected 3C-97-0E-A7-97-B1          0 bps
 Wi-Fi                     Intel(R) Centrino(R) Advanced-N 6205         22 Up           6C-88-14-A0-21-D4       240 Mbps
 vEthernet (WSL)           Hyper-V Virtual Ethernet Adapter #2          55 Up           00-15-5D-48-9C-CB        10 Gbps
 VMware Network Adapte...8 VMware Virtual Ethernet Adapter for ...      18 Up           00-50-56-C0-00-08       100 Mbps
 VMware Network Adapte...1 VMware Virtual Ethernet Adapter for ...      16 Up           00-50-56-C0-00-01       100 Mbps
 Bluetooth Network Con...3 Bluetooth Device (Personal Area Ne...#3      10 Disconnected B8-76-3F-AE-34-17         3 Mbps
 vEthernet (Default Swi... Hyper-V Virtual Ethernet Adapter             48 Up           00-15-5D-AD-10-A6        10 Gbps
 Local Area Connection 2   TAP-ProtonVPN Windows Adapter V9              5 Disconnected 00-FF-10-C8-AD-3F         1 Gbps
 Local Area Connection     PPPoP WAN Adapter                             2 Disconnected 00-00-00-00-00-00          0 bps
    
    
    
 PS C:\WINDOWS\system32> Import-Module -Name "C:\Program Files\Intel\Wired Networking\IntelNetCmdlets\IntelNetCmdlets" -Scope Local
    
 PS C:\WINDOWS\system32> Add-IntelNetVLAN -ParentName "Intel(R) 82579LM Gigabit Network Connection" -VLANID 111
    
 VLANID VLANName                                       ParentName                                                     
 ------ --------                                       ----------                                                     
 111    VLAN111                                        Intel(R) 82579LM Gigabit Network Connection                    
    
    
    
 PS C:\WINDOWS\system32> Get-NetAdapter
 Get-NetAdapter : The data is invalid. 
 At line:1 char:1
 + Get-NetAdapter
 + ~~~~~~~~~~~~~~
     + CategoryInfo          : InvalidData: (MSFT_NetAdapter:ROOT/StandardCimv2/MSFT_NetAdapter) [Get-NetAdapter], CimException
     + FullyQualifiedErrorId : Windows System Error 13,Get-NetAdapter
     
    
 PS C:\WINDOWS\system32> 

Once the vLAN is removed, functionality is restored

 PS C:\WINDOWS\system32> Remove-IntelNetVLAN -ParentName "Intel(R) 82579LM Gigabit Network Connection" -VLANID 111
    
 PS C:\WINDOWS\system32> Get-NetAdapter
    
 Name                      InterfaceDescription                    ifIndex Status       MacAddress             LinkSpeed
 ----                      --------------------                    ------- ------       ----------             ---------
 Ethernet 3                Fortinet SSL VPN Virtual Ethernet Ad...      26 Not Present  00-09-0F-AA-00-01          0 bps
 Ethernet 2                Fortinet Virtual Ethernet Adapter (N...      24 Disconnected 00-09-0F-FE-00-01       100 Mbps
 Ethernet                  Intel(R) 82579LM Gigabit Network Con...      14 Disconnected 3C-97-0E-A7-97-B1          0 bps
 Wi-Fi                     Intel(R) Centrino(R) Advanced-N 6205         22 Up           6C-88-14-A0-21-D4       216 Mbps
 vEthernet (WSL)           Hyper-V Virtual Ethernet Adapter #2          55 Up           00-15-5D-48-9C-CB        10 Gbps
 VMware Network Adapte...8 VMware Virtual Ethernet Adapter for ...      18 Up           00-50-56-C0-00-08       100 Mbps
 VMware Network Adapte...1 VMware Virtual Ethernet Adapter for ...      16 Up           00-50-56-C0-00-01       100 Mbps
 Bluetooth Network Con...3 Bluetooth Device (Personal Area Ne...#3      10 Disconnected B8-76-3F-AE-34-17         3 Mbps
 vEthernet (Default Swi... Hyper-V Virtual Ethernet Adapter             48 Up           00-15-5D-AD-10-A6        10 Gbps
 Local Area Connection 2   TAP-ProtonVPN Windows Adapter V9              5 Disconnected 00-FF-10-C8-AD-3F         1 Gbps
 Local Area Connection     PPPoP WAN Adapter    

This is not related to the ProSet powershell modules, as this happens if if they are not loaded, and does not seem to be related to the vendors, as this happens in Dell and Lenovo machines alike.
It seems that is asked in Intel forums as well, but with no clear answer.

Any ideas?

windows-10-networkwindows-10-application-compatibility
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This is a quick note to let you know that I am currently performing research on this issue and will get back to you as soon as possible. I appreciate your patience.
If you have any updates during this process, please feel free to let me know.

0 Votes 0 ·

1 Answer

SunnyQi-MSFT avatar image
0 Votes"
SunnyQi-MSFT answered ·

Hi,

Thanks for posting in Q&A platform.

May I know if the same issue occurred with other brand's VLAN?

If the function can work successfully after removing Intel VLAN, it seems that there is a compatibility issue between windows and Intel. I haven't found any Microsoft official documents talking about this scenario. I would suggest you could contact Intel support for getting a satisfied answer.

https://www.intel.com/content/www/us/en/support/contact-support.html

Best Regards,
Sunny


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 3 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

There is an issues open with Intel (see: 1258968). They do not seem have a clue (yet, at least)


0 Votes 0 ·

Hi,
 
Just want to confirm the current situations.
 
Please feel free to let us know if you need further assistance.

You could accept the useful reply as answer if you want to end this thread up. If there is anything else we can do for you, please feel free to post in the forum.
 
Best Regards,
Sunny

0 Votes 0 ·

You could accept the useful reply as answer if you want to end this thread up. If there is anything else we can do for you, please feel free to post in the forum.

0 Votes 0 ·