question

hidracampos avatar image
0 Votes"
hidracampos asked RamaMohanaCharyAkavarapu-4424 commented

invalid_resource AADSTS500011

My application was working without any problems, when suddenly the app had a white screen and printing the following error on the console:

AUTHMSAL: Event: adal:tokenRenewFailure, code: invalid_resource|AADSTS500011: The resource principal named https://... was not found in the tenant named <Directory ID>. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You might have sent your authentication request to the wrong tenant.
Trace ID: <Trace ID>
Correlation ID: <Correlation ID>
Timestamp: 2021-03-01 15:38:07Z, resource: https://..., action: resourceDisabled

Any help?

office-teams-app-devmicrosoft-graph-teamwork
· 9
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @FelipeCampos-6283,

As stated in the error message, this can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. The IT administrator of the company with xyz domain (email@xyz.onmicrosoft.com) has to give consent on behalf of the whole company so that the users of that company will be able to use your application.

It can also happen if the app is registered in the wrong tenant or the code for the apps do not have the right references to the app registration.

Could you please check once.

0 Votes 0 ·
hidracampos avatar image hidracampos RamaMohanaCharyAkavarapu-4424 ·

Yes! I'm using a Administrator user to install the app but the error still happen!

0 Votes 0 ·

Hi @FelipeCampos-6283,

Have you followed the ReadMe file in this document.


0 Votes 0 ·
Show more comments

1 Answer

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered JimmyYang-MSFT commented

Hi @FelipeCampos-6283,

Are you using Microsoft Teams application?

Does this issue persist on other Office applications?

According to your error message, this issue is possibly the authentication request sent to the wrong Azure AD. In this case, we firstly recommend you verify if the error message’s tenant ID is the same as your tenant ID. If you don’t know your tenant ID, you need to login Azure Active Directory Admin center and click “Properties” on the left hand side navigation, then you can see your Directory ID in your tenant.
73332-21.png


In addition, to exclude the client issue, you can try to login Teams web client. If you can login normally, please try to clear your client cache file in Microsoft Teams and make sure you have the newest version of client.



If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



21.png (36.6 KiB)
· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @FelipeCampos-6283,

Any update?

0 Votes 0 ·

Hi @JimmyYang-MSFT!

Yes, Yes, it's a Team app and the Tenant ID is correct!

I'm using a OAuth 2.0 authentication for the tab ... It was working normally a few weeks ago. I didn't change anything!

To develop the Team App authentication, I followed this documentation: https://docs.microsoft.com/en-us/microsoftteams/platform/tabs/how-to/authentication/auth-tab-aad

In addition, I tried to create a new application on Azure (https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationsListBlade), updated the manifest with the new application ID, but I had the same problem ... white screen and no error logs this time!

I have a Addin App that is on the same Tenant and it is working very well! Just the Team app is not working...

0 Votes 0 ·

@JimmyYang-MSFT
Do you have another tip for me?

0 Votes 0 ·

@hidracampos

Have you tried @RamaMohanaCharyAkavarapu-4424 suggestion to check the token?

0 Votes 0 ·
Show more comments