question

yaronbenshalom-7501 avatar image
0 Votes"
yaronbenshalom-7501 asked ·

SHarePoint 2019 not crawling/searching user profile propoerties

We have a SharePoint 2019 farm that was upgraded from 2013 a few months ago.
User profiles are synchronized using AD import and seem to be updated correctly.
Search is crawling those profiles and also seems to be working correctly (at least as far as the crawl log goes; the only error while crawling "My Sites" is related to "Style library" not being crawlable).
The user's "My site" is accessible, but does not display all the property values that appear in the UPS profile.
The problem is that not all user properties are not reflected when searching for users.
We get the name only, no phone or title or anything else.
The only error in the ULS is this:

Not valid TaxonomyTerm from string '<some user property or another>'

It should be noted that this error seems to appear for many users that do not display this problem while searching for them.
Perhaps they where successfully crawled sometime before this started to happen.


office-sharepoint-server-itprooffice-sharepoint-server-search-itpro
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, @yaronbenshalom-7501 ,

After a few days, is there any update?

0 Votes 0 ·
sadomovalex avatar image
0 Votes"
sadomovalex answered ·

based on what you provided from the log - did you check whether those user profile properties which are bound to taxonomy term sets are still valid and may be filled? During migration ids of terms sets could be changed which could broke these properties.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JerryXu-MSFT avatar image
0 Votes"
JerryXu-MSFT answered ·

Hi, @yaronbenshalom-7501 ,

Just like sadomovalex said, it may be better to first double check the range of the issue. Make sure if the properties are using term sets which are not migrated properly. Which of the properties cannot be crawled? And How many users are suffering from this problem?

Here is a thread with similar situation:https://social.technet.microsoft.com/Forums/ie/en-US/72bb0f0f-8193-4e00-9886-51d89b93ee05/sharepoint-2013-user-profile-service-search-crawl-errors?forum=sharepointsearch


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.