question

akg777-0588 avatar image
akg777-0588 asked ·

Unable to Install/Import Pandas on Azure App Service

Hi,

I have been trying to install Pandas on my Azure App Service (running Flask) for a long time now but nothing seems to work.

I tried to use wheel, created a wheelhouse directory manually and tried to install the relevant Pandas .whl file (along with its dependent packages) but it still doesn't work. This approach gives me the following error -

"Could not find a version that satisfies the requirement" "No matching distribution found for ..."

A simple "pip install pandas" also doesn't work - when I do this, in my Kudu Bash client the command gets stuck on "Cleaning up.." and nothing gets installed.

azure-webapps
3 comments
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

UPDATE: I have been able to install Pandas, but have a question - I need to reinstall it everytime I currently deploy my app (using the az webapp up command). Is there a way I can ensure that I don't need to reinstall it after every deployment?

0 Votes 0 · ·

can you included this as part of your requirements.txt?

0 Votes 0 · ·

Just checking in if you have had a chance to see the previous response. You may refer to below doc link might be helpful.

https://docs.microsoft.com/en-us/archive/blogs/azureossds/install-native-python-modules-on-azure-web-apps-api-apps#install-requirements-on-azure-app-services

0 Votes 0 · ·

0 Answers