question

ArtakTc-8917 avatar image
2 Votes"
ArtakTc-8917 asked ·

VS 2019 After the latest update 16.9 Errors shown

Visual Studio 2019 has stopped working after update 16.9 was installed. I get errors such as "package did not load correctly". Does anyone else have this issue? I did tried many things such as re-installing but no matter what I did the issue still remains.

vs-setup
· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @ArtakTc-8917 ,

Welcome to Microsoft Q&A!

According to your description, please close all instances of Visual Studio and delete the following folder:
%localappdata%\Microsoft\VisualStudio\16.0_xxxx\ComponentModelCache

Then, relaunch your Visual Studio as administrator and check if the error is disappeared.

Meanwhile, you can also try to repair your Visual Studio by opening your installer -> More -> Repair.

Sincerely,
Anna


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




0 Votes 0 ·

issue addressed partially. As administrator issue is gone but not as regular user. See comment below.

1 Vote 1 ·
ArtakTc-8917 avatar image
2 Votes"
ArtakTc-8917 answered ·

When I run Visual Studio as administrator it works. When I run as a normal user error displayed in popup "The 'Environment Package Window Manager' package did not load correctly" and Visual Studio fails to open.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BenTesch-1679 avatar image
1 Vote"
BenTesch-1679 answered ·

I have the same issue, and deleting the %localappdata%\Microsoft\VisualStudio\16.0_xxxx\ComponentModelCache folder doesn't help. Running as administrator does.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AnnaXiu-MSFT avatar image
0 Votes"
AnnaXiu-MSFT answered ·

Hi @ArtakTc-8917,

It has been reported to product team, you can view the similar issue: https://developercommunity.visualstudio.com/t/Error-The-Environment-Package-Window-M/1356392?space=8&q=Environment+Package+Window+Management+package+did+not+load+correctly+run+Visual+Studio+2019+as+administrator.

You can also add your comments in there to track the process. If there is any update, I will also add it here.

Thanks for your understanding.

Sincerely,
Anna


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



· 2 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you @AnnaXiu-MSFT

0 Votes 0 ·

My pleasure!

0 Votes 0 ·
WiseyD-8563 avatar image
0 Votes"
WiseyD-8563 answered ·

I'm having the same issue. Happened after update to 16.9.1

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ArtakTchalgouchian-3998 avatar image
0 Votes"
ArtakTchalgouchian-3998 answered ·

latest update 16.9.2 fixes the issue. Thank you Microsoft!

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.