question

Damien471-9313 avatar image
0 Votes"
Damien471-9313 asked ·

Limit RDP Connections to one user at a time

Hi,
I have a Windows Server 2016 setup without RDS installed.
I am currently able to login with two separate users simultaneously.
In an effort to restrict this I have set RDP Connection Limit to 1 in GP:
Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connection
Number of sessions per user is also set to 1.
I done a gpupdate /force and a full PC restart but two users are still able to connect simultaneously. If I try to log on with a third user I am then prompted that two users are currently active.

windows-virtual-desktop
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ManuPhilip avatar image
0 Votes"
ManuPhilip answered ·

Hello @Damien471-9313,

Looks like another GPO is blocking it. Use rsop.msc and get all active GPO settings and disable/fine-tune the other GPOs so that this one will work


Please mark as "Accept the answer" if the above steps helps you. Others with similar issues can also follow the solution as per your suggestion

Regards,

Manu

· 2 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @ManuPhilip ,
I ran rsop and the only policy that is being applied to the machine is the policy limiting the number of rdp connections.

Regards,
Damien

0 Votes 0 · ·

Hello,

I see the issue here. The settings you are playing with is to limit unique user session to one. That can't limit multiple RDP from different user names.
In gpedit.msc, navigate to: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections. Set the Restrict Remote Desktop Services user to a single Remote Desktop Services session parameter to Enabled,

Thanks,
Manu

0 Votes 0 · ·