question

WillT-5055 avatar image
0 Votes"
WillT-5055 asked ·

Iphones cannot connect via ActiveSync since 2016 CU19 and KB500087

Hi, have upgraded a client 2016 server to CU19 and installed patch for KB500087 and since then all iphones can no longer connect via activesync using the native mail client. Outlook client connects, I can setup an android device as well but any new or existing iphones fail to connect. The active analyser passes just fine and I can go through the process of setting up an account and verifying the account, but when it comes to actually retrieving email, it just say it cannot get mail as the connection to the server failed. I've tried rebooting the devices, deleting and re-adding the accounts, same issues. If I enable activesync logging, it doesn't show any errors, nothing in the events logs either so baffled. Any help appreciated and it was def working prior to this update.

office-exchange-server-connectivity
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, @WillT-5055
Did you mean if using the Outlook client on IOS, it won't have any connection problem?
Android devices are also working fine,the problem is only with IOS native mail client.
If I misunderstood anything,please feel free to correct me.

If so, I suppose that activesync should be working fine.
Have you tried with other third-party clients (for example gmail)?

And can you find some detailed information of the failed connection logged in the IIS log?
Please note that by default the IIS log uses UTC time.

0 Votes 0 ·
WillT-5055 avatar image
1 Vote"
WillT-5055 answered ·

Hi KaelYao,

All solved. Seems it was a number of things. Needed to run UpdateCAS, then for some reason the readahead settings had all ben set to 0. Set them back to what they should be, run iisreset and sprung back into life!

· 2 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, @WillT-5055
Glad to hear that and thank you very much for the sharing!

0 Votes 0 ·

Hi Will,
Where is this "readahead" setting?
What should it be set to?
Thanks!

0 Votes 0 ·
WillT-5055 avatar image
0 Votes"
WillT-5055 answered ·

Configuration Editor in IIS under the Active Sync Web site. Open that, then system.webserver/serverRuntime there the uploadreadahead setting, I've set it to 500000

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.