question

ZeiserThomasSHSDIDHTPOPS-2183 avatar image
0 Votes"
ZeiserThomasSHSDIDHTPOPS-2183 asked JimmyYang-MSFT commented

NDI not supported on Mac

Hi, I am running macOS Big Sur 11.2.1 on my MacBook Air (newest model). Trying to create my recording setup I had before on a windows machine: MS Teams with NDI feature activated -> Record streams with OBS Studio Unfortunately I cannot activate my NDI feature in MacOS. NDI feature is available in Settings, however when activating it, it always goes to "NDI not supported" immediately. Any suggestion how to fix this? Below you is the log from Teams folder log.txt
Thanks!




Fri Mar 05 2021 16:36:08 GMT+0100 (Mitteleuropäische Normalzeit) <2023> -- event -- slimcoreVersion: 2020.38.23, isSlimCoreHotSwapped: false, reason: NDI libraries already present, reasonCMD: NDI libraries already present, status: abandoned, scenario: 46cbfefe-3578-47a6-b3c7-41b3f77738fc, scenarioName: intialize_ndi, name: intialize_ndi, step: stop, sequence: 1, delta: 10, scenarioDelta: 10, elapsed: 66731, stepDelta: 9, vdiMode: 0, eventpdclevel: 2, Scenario.Name: intialize_ndi, Scenario.Step: stop, Scenario.Status: abandoned,



office-teams-windows-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered JimmyYang-MSFT commented

Hi @ZeiserThomasSHSDIDHTPOPS-2183

Does this issue exist all the time?

Does anyone else have the same issue in your organization?

In this case, we firstly recommend you try to disable GPU acceleration in the general settings and then restart Teams to see if works for you. Some users also met this issue and the solution is useful for them. For more discussion about it, you can refer to:

https://techcommunity.microsoft.com/t5/microsoft-teams/ndi-is-not-supported-error-message/m-p/1683050

At the same time, please make sure you have the newest version of Teams client.


If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @JimmyYang-MSFT thanks for the reply.

unfortunately I did both:
1. Unistalled Teams
2. Deleted all related files
3. Installed with the newest version
4. Disabled GPU acceleration

Still I get the error every time I try to activate it.

I also did export diagnostic logs. could provide them if necessary.
Thanks!



0 Votes 0 ·
JimmyYang-MSFT avatar image JimmyYang-MSFT ZeiserThomasSHSDIDHTPOPS-2183 ·

@ZeiserThomasSHSDIDHTPOPS-2183

I found a workaround for the "NDI is not supported" issue:

1.Close Teams
2.Open %LOCALAPPDATA%\Microsoft\Teams\current\resources\app.asar.unpacked\node_modules\slimcore\bin
3.Delete "Processing.NDI.Lib.x64.dll", "Processing.NDI.Lib.Licenses.txt", and "TxNdi.dll"
4.Restart Teams
5.Go to Settings > Permissions and tick NDI, it should redownload the libraries and work.

0 Votes 0 ·

Hi @JimmyYang-MSFT

you posted the Windows path above
I find somewhat similar files on the Mac here:

Library/Application\ Support/Microsoft/Teams/plugins/ndi/2020.38.01.23/bin/

libTxNdi.dylib libndi.4.dylib libndi_licenses.txt

However deleting those and restarting Teams didn't work.
It downloads the same files again... but then we have the "not supported" error again.
Any other suggestions? Shall I send my logs over to you?

Thanks!
Thomas

0 Votes 0 ·
JimmyYang-MSFT avatar image JimmyYang-MSFT ZeiserThomasSHSDIDHTPOPS-2183 ·

Hi @ZeiserThomasSHSDIDHTPOPS-2183

Could you provide more diagnostic logs screenshot about this issue? Maybe we can find some clues from it.

In addition, please note that not all users can access the NDI® technology stream:

In-tenant – full support, delivered based on ring/tenantId/userId (controlled by Meetings Policy)
Federated – no stream access (even when they have NDI® technology on)1
Premium - no stream access
Anonymous – no stream access
Guest – no stream access

0 Votes 0 ·

Hi @JimmyYang-MSFT

NDI is activated for my user as I can use it on my windows machine.

Attached a screenshot of the error message in the GUI and in logs.txt79634-bildschirmfoto-2021-03-19-um-135929.png.

Your help is very much appreciated. I can also send over the my machine settings and the entire logfile, if needed.
Thanks!
Thomas

79684-bildschirmfoto-2021-03-19-um-135051.png


0 Votes 0 ·
Show more comments