question

HattendorfAnton-4228 avatar image
HattendorfAnton-4228 asked ·

Microphone is not working

Hello

I have a Problem with the Microphone in Teams on Linux:

  • Teams is complaining, that the microphone is not working.

  • In the device configuration I can select multiple microphones.

  • Teams shows no level for any microphone.

  • In the Pulse Audio Volume Control I can see level for all microphones.

  • I also see the Recording Channel of Teams (with label "Skype" :-) ) and it receives level.

Video is working fine.

Thanks in advance for your help.

Greetings,
Anton Hattendorf


office-teams-linux-itpro
1 comment
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Anton. What version are you using? Can you click your photo / About / Version and share?

0 Votes 0 · ·
omarkhalidMSFT avatar image
omarkhalidMSFT answered ·

@HattendorfAnton-4228 thank you for trying Teams for Linux and for sharing your feedback. If you'd prefer, our support team can work with you over phone/email and try to troubleshoot the issue. Please go to https://admin.microsoft.com and create a support request so our team can contact you and resolve the problem.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DionVansevenant-6742 avatar image
DionVansevenant-6742 answered ·

I have had similar issues on Fedora 31 using the official linux preview client and a Sennheiser USB-ED 01 headset. Same hardware works fine when I reboot into Windows 10. I have opened a ticket, but wanted to post to show that others have similar issues.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TostivintCyril-0797 avatar image
TostivintCyril-0797 answered ·

Same issue for me, I'm using the Team Client on Ubuntu 18.04 with Gnome desktop.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ErikP-4574 avatar image
ErikP-4574 answered ·

Hi!

I am too having this or a very similar issue on Ubuntu 19.10 when using USB connected Sennheiser Momentum 2 or a Jabra 510 puck:

  • Teams will show all devices in the selector menu and I can select the headset or puck.

  • Sometimes I get no functional microphone or the internal mic on the HP latptop is selected.

  • Sometimes I can get things working by opening the OS sound prefs panel during the call. This one could possibly point this to be an OS issue, but other apps are unaffected.

  • I typically need to completely restart teams after having inserted a USB audio device in order to get it to work.

/Erik



Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JSouth-8397 avatar image
JSouth-8397 answered ·

Has there been any solution offered?

I have this same issue, with my laptop's built-in mic, a Logitech webcam mic, and a Bluetooth headset mic all showing as available, but with no audio levels.

All hardware is functioning well in other applications. (And in Windows.)

This is clearly a showstopper for the adoption of Teams in multi-OS environments ― any troubleshooting hints would be appreciated.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LarsLansink-4404 avatar image
LarsLansink-4404 answered ·

Bump!

Any solution to this?

Teams in Google Chrome works flawless, but the native teams client wont record mic.

Would be nice to have this working as good as the web app since it has some other features that are nice when "Teaming"

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SeThuAung avatar image
SeThuAung answered ·
3 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This is just a wrapper around the webclient, native client is better in a few ways.

0 Votes 0 · ·

Yes, that it is - but it's a good stopgap as a "standalone app" while this problem exists.

0 Votes 0 · ·

There is another problem report for the Linux preview elsewhere here - the complaint that it is using horrendous amounts of CPU. I have that problem (50% itself and an associated kernel thread at 20%). This wrapper solution also circumvents both of those problems - so I'm sticking with it for now. THANK YOU @IsmaelMartinez


0 Votes 0 · ·
StephanSnyman-5956 avatar image
StephanSnyman-5956 answered ·

I've had the same issue. Except sometimes the mic works but there is no audio output. I have found when you go to device settings, if you set the mic and the audio output to "default device" then they both work.

However "default device" does not always show up as an option. And the only thing I know that sometimes makes it work is to either restart teams, or to restart your pc. Again this only sometimes works.

I am not sure why teams doesn't always detect the same devices.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JensHektor-5473 avatar image
JensHektor-5473 answered ·

My guess is that the code for USB based audio could be better.
A logitech Cam has mostly a MIC also, this is not found.

VLC does not have this problem.

I guess that on some laptops is the same problem with built in CAM/MIC Kombination.

Would be great, if this could get fixed soon.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JensHektor-5473 avatar image
JensHektor-5473 answered ·

Running it as "root" may solve the problem.

Then USB based MICs are found. Tststs.

Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.