question

Prabs-7622 avatar image
0 Votes"
Prabs-7622 asked ·

Visual Studio version for .net core application

Hi,
I am going to develop .NET core console application.
For that, Which Visual Studio development version is better for .NET core console application?

Currently i have Visual Studio 2015 and 2017 in my machine.

Please help me on this.

vs-setupdotnet-runtime-coredotnet-runtime-framework
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Castorix31 avatar image
0 Votes"
Castorix31 answered ·
· 2 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

what about Visual Studio 2015 and 2017?
For commercial purpose, Is community version supported?


0 Votes 0 ·

Then choose 2017 : it supports .NET 2.1 or 2.2, from :
Install with Visual Studio



0 Votes 0 ·
DylanZhu-MSFT avatar image
0 Votes"
DylanZhu-MSFT answered ·

Hi Prabs,

The visual studio 2017 is better. You can develop with .net core 2.1, which is under long term support.

But visual studio 2015 just supports .net core 1.0, which is out of support. The reference: https://dotnet.microsoft.com/download/dotnet
Best Regards,
Dylan


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 6 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

But .net core 2.1 support ends on 2021-08-21.
Is there any issue if i go for .net core 2.1 in Visual studio 2017? because support ends this year august

0 Votes 0 ·

It's just that this framework is no longer maintained, but you can continue to use it.

1 Vote 1 ·

In my Visual Studio 2017, .NET core project is not available. Only .NET framework available
How to add .NET core in Visual Studio 2017?

0 Votes 0 ·
Show more comments

Thanks for your help

0 Votes 0 ·

Thanks for your help

0 Votes 0 ·