question

angela83 avatar image
0 Votes"
angela83 asked ·

Retrieve an online meeting by JoinWebUrl stopped working in Beta API

Hi Team

Retrieve an online meeting by JoinWebUrl as documented here onlinemeeting-get was working fine on Monday 8th of March and it stopped working yesterday and today is still not working. I am getting the following error on the GET request

"The query specified in the URI is not valid. Could not find a property named 'JoinWebUrl' on type 'Default.<>f__AnonymousType0_1Of<>f__AnonymousType1_2OfString_String'."

Is there any reason for this or is someone else facing the same issue?


microsoft-graph-general
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

angela83 avatar image
0 Votes"
angela83 answered ·

Hi @Danstan agreed /beta apis are subject to change.
I have just tried it again and it is still failing for me. I am first getting the joinWebUrl from a callRecord and pasting it as is to get the onlineMeeting as below
Am I doing anything wrong here? does it work for JoinWebUrl that are a few days old?

76789-callrecord.png


76790-onlinemeeting.png



callrecord.png (66.9 KiB)
onlinemeeting.png (72.4 KiB)
· 3 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Can you try with an event created today? The old events may have different version for the joinWebUrl.

0 Votes 0 ·

It worked fine on a meeting I just did. Is there a timeframe for when it will work and is there a way to make it work for meeting that are older than a day for example?

0 Votes 0 ·

About how to make it work for older meetings I don't have an idea as this is a beta API. Please consider accepting the answer to help other users.

0 Votes 0 ·
Danstan avatar image
0 Votes"
Danstan answered ·

First, APIs under the /beta version in Microsoft Graph are subject to change and are not supported for use in Production so keep this in mind.

That said, the endpoint works fine for me. I think you are using a link that is not a valid JoinWebUrl or it points to a meeting that does not exist. Here is a sample

 https://teams.microsoft.com/l/meetup-join/19%3ameeting_MWE3NjIwNTYtNWIzYi00YzViLWE0ZGMtMjg0YmFlODIwYjdi%40thread.v2/0?context=%7b%22Tid%22%3a%22db8a372f-db02-4791-b30b-df0bcec9bdb3%22%2c%22Oid%22%3a%222f43e7ac-7ef9-44de-8518-2c8d0f0668c6%22%2c%22IsBroadcastMeeting%22%3atrue%7d

See the screenshot below
76821-online-meetings.png



online-meetings.png (123.7 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.