question

MikeBerkley-8218 avatar image
9 Votes"
MikeBerkley-8218 asked ·

Linux version 1.4.00.4855 of teams no longer takes a URL on the command line, which breaks xdg-open from Chrome/Firefox

The 1.4.00.4855 version of teams on Linux no longer takes a URL on the command line.
This means that xdg-open is no longer able to open a teams meeting, so you cannot open meeting links from Chrome or Firefox

Downgrading to 1.3.00.30857 allows /usr/bin/teams to take a URL on the command line and xdg-open works as expected.

I can think of no other workaround to get meeting links to work than reverting to 1.3.00.30857.

office-teams-linux-itpro
· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Since the most recent update - I think I'm having a similar issue. Clicking the meeting link within Firefox web based outlook calendar opens up teams but does not launch a meeting any longer. It does go to teams - but the join now screen does not appear. I can still join meetings from within Teams - by clicking the join now in the purple box. I'm running Mint 20.1 for reference. Everything else seems to work fine - this has only broken in the past few days.

2 Votes 2 ·
JimmyYang-MSFT avatar image JimmyYang-MSFT PaulMMauriksDJCS-7892 ·

@MikeBerkley-8218, @Benny-9516

We can confirm that this is a bug now. Microsoft will fix it with next version.

Thanks for your patience and understanding.

2 Votes 2 ·
JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered ·

Hi @MikeBerkley-8218,

Thanks for your feedback!

What is your Linux OS version in your environment?

I did a test in Unbuntu 20.04 and found we cannot join Teams meeting on web client. The following steps are for your reference:

1.Run the command “xdg-open <teams meeting URL>”in the Terminal
76615-6.png


2.It will pop out a browser but there is no option to join Teams meeting in web client. If you quit the Teams client, it will start Team client again automatically.
76616-7.png


3.Using Teams-insider client and Teams-preview client(Version is 1.4.00.4855) and have the same result.

We still need to investigate more about this issue, if there is any news, we will inform you in time!



If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


6.png (31.1 KiB)
7.png (54.6 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Benny-9516 avatar image
2 Votes"
Benny-9516 answered ·

Here you can find the solution. You need to adjust /usr/bin/teams

@JimmyYang-MSFT you should share this code with the devolopment team so that they know how to fix it.


· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @Benny-9516

Thanks for your information about this issue. I will do it!

0 Votes 0 ·
PaulMMauriksDJCS-7892 avatar image
2 Votes"
PaulMMauriksDJCS-7892 answered ·

As suggested by Benny-9516 this approach definitely worked for me.

Change:
nohup "$TEAMS_PATH" --disable-namespace-sandbox --disable-setuid-sandbox "$@" > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
To:
nohup "$TEAMS_PATH" "$@" --disable-namespace-sandbox --disable-setuid-sandbox > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
in /usr/bin/teams

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Benny-9516
@PaulMMauriksDJCS-7892

Worked like a charm for me thank you very much!

2 Votes 2 ·