question

KlaatuWithGort-6214 avatar image
0 Votes"
KlaatuWithGort-6214 asked Dgorter commented

JAPANESE CHARACTERS

NONE of the solutions proposed on the internet works. I want to display ENGLISH but if I have a file with Japanese characters I want them to display. This works fine on my Android tablet, but not on my Windows 10 PC. I can't find any solution. I HAVE the IME Japanese pack and bottom right can select it from a small group of languages, but selecting Japanese makes NO difference. The SAME file displays Japanese on my tablet but not on my PC. I am baffled.

windows-10-setup
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello,
Have you tired installing the Optional Japanese supplemental fonts?
Start
Settings
Apps
Optional Features
Add a Feature
Japanese Supplemental Fonts

0 Votes 0 ·
CarlFan-MSFT avatar image
0 Votes"
CarlFan-MSFT answered

Hi,
I consider that you could try to check "Language for non-Unicode programs" option.
Open Control Panel, the “Region and Language” window. Go to the Administrative tab. In the “Language for non-Unicode programs” section, you see the currently set language for these apps and programs. To change it, click or tap “Change system locale.”
The Region Settings window is displayed. By default, you see the current language that is used for non-Unicode apps and files.
Click or tap the “Current system locale” drop-down list to view all the languages that you can choose from. Select the new language that you want to use and press OK.
Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KlaatuWithGort-6214 avatar image
0 Votes"
KlaatuWithGort-6214 answered

Thanks for trying"! In the Admin page you mention I have chosen Japanese in the "Current system locale" box and clicked on the "Change systeme locale" box (Why is it in French?!!) where it says:

"Beta: use Unicode-UTF 8 for worldwide language support", but it makes no difference.

I even tried setting the Windows display language to Japanese, but that made no difference either! I never had this problem with Windows 7!!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CarlFan-MSFT avatar image
0 Votes"
CarlFan-MSFT answered

Hi,
I'm sorry to see your message when I just came back from vacation.
Check to make sure you have Japanese set as your language for non-unicode programs
Press "Change System Locale" and select "Japanese (Japan)" from the drop-down menu.
To make sure the box that says "Beta: Use Unicode UTF-8 for worldwide language support" is UNCHECKED, this causes a heap of problems for programs and files that just cause them to appear strange or incorrectly. Upon unchecking this, the problems I was having with programs and files disappeared entirely, and I was able to use everything correctly again.
Just like the information in the link below, as far as I know this is the only relevant setting in the system Settings.
https://www.digitalcitizen.life/changing-display-language-used-non-unicode-programs/
For Windows 10, I remember it has changed Unicode format. So it may affect character display. In the meantime, I recommend that you update your system to the latest version to check.
Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.