question

Chong-7118 avatar image
0 Votes"
Chong-7118 asked joyceshen-MSFT commented

Exchange 2016 failed to schema update

Hi Support,

Our exchange 2016 is cu9 which install in child domain, and will patch to cu19. When we run the "prepareschema" in root domain's Schema master DC, it show below error:


76646-schema.jpg

  • We checked the account is member of "Schema Admin", "Enterprise Admin", "Domain Admin" and "Organization Management".

  • The forest functional level and domain functional level is 2016

  • Tried to create another admin account with required permission also have the same error.

  • Tried to run the "prepareschema" in other server which in the same AD site

  • All DC restarted and replication is good

Any idea?

Thanks
Chong


office-exchange-server-administrationoffice-exchange-server-itpro
schema.jpg (107.0 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @Chong-7118

Is there any update?

0 Votes 0 ·
TroyWerelius-7253 avatar image
0 Votes"
TroyWerelius-7253 Suspended answered
  • Sounds like an DNS related issue so I would start by validating the Exchange Server DNS settings are correct

  • The other action to consider would be to do an AD Health check

  • I would also check the local groups to ensurer there are no abandoned/orphaned entries, i.e. they will show as a GUID vs a username

Search, Recover, & Extract Mailboxes, Folders, & Email Items from Offline Exchange Mailbox and Public Folder EDB's and Live Exchange Servers or Import/Migrate direct from Offline EDB to Any Production Exchange Server, even cross version i.e. 2003 --> 2007 --> 2010 --> 2013 --> 2016 --> 2019 --> Exchange Online with Lucid8's DigiScope






5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

joyceshen-MSFT avatar image
0 Votes"
joyceshen-MSFT answered

Hi @Chong-7118

Please check the ExchangeSetup log to see more related information. Make sure you have meet all the prerequisites list in the official document here: Exchange Server prerequisites

In addition, have you tried running the prepare AD command manually? Prepare Active Directory and domains for Exchange Server


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
 

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Chong-7118 avatar image
0 Votes"
Chong-7118 answered joyceshen-MSFT commented

Hi @joyceshen-MSFT

I double check the prerequisites and my environment should meet the requirement. The Exchange log don't have more detail, I can see the same error message as the capture screen and many "Active Directory operation failed on . The supplied credential for 'domain\admin' is invalid." error. But the account should be member of "Schema Admin", "Enterprise Admin", "Domain Admin" and "Organization Management".

I didn't try to run the prepareAD command, as the prepareSchema command not work. I know run prepareAD will include prepareSchema also. But have any different with run the prepareSchema first?

Thanks
Chong

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi

How many DC/GC you have in your environment? Check the application log on exchange server related to AD events.

0 Votes 0 ·