question

AndrewJames-1941 avatar image
0 Votes"
AndrewJames-1941 asked ·

SharePoint Online - Search reports contain 0 results

We are running the search reports (located in Site Settings - Search Report-Alerts*) but the return results for days / months is always 0. We know our users search our sites, is there something I need to enable for it to capture this data. I have tried searching around and found articles to enable audit settings and turning on some features but these seem to be deprecated now with the move of the reports from the Admin portal to site settings.

Regards Andrew

office-sharepoint-online
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

AllenXu-MSFT avatar image
0 Votes"
AllenXu-MSFT answered ·

Hi @AndrewJames-1941,

Does this issue only occur to one site collection or multiple site collections? To get a search report, it is enough to enable Reporting feature generally. And also, is there any data in your tenant-level search report? Please check it via SharePoint admin center -> search -> View Usage Reports. As I couldn't replace this issue in my end, it's hard to go on further troubleshooting. I suggest you new a service request in Microsoft 365 admin center.
77097-1.png


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1.png (19.8 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.