question

DatTruongManh-1313 avatar image
0 Votes"
DatTruongManh-1313 asked ·

The administrative template file failed to be sent to the device. (ERROR CODE: 0x20101)

Hi,
So I encounter this error code when verifying the installation status of Edge configuration profile to a Windows 10 Home Single Language device. This error however is not reproduced on other edition of Windows such as Edu, Pro or Enterprise. The only settings in the Edge configuration profile is URLBlocklist policy.

Device OS build is 19042.867, version 20H2 and MDM enrolled.
Edge version is 89.0.774.48 (64-bit).

There are another article about this issue but neither the cause or solution is provided.

Is there anything I can do to solve this issue?

Thank you,
Best regards.

mem-intune-generalmem-intune-device-configurations
· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@DatTruongManh-1313 Thanks for posting in our Q&A.

To clarify this issue, we appreciate your help to get screen shot of the specific administrative template settings of Edge. Thanks!


0 Votes 0 ·

Hi,
Thanks for replying.
Here are the screenshots for the policy which I set for Edge Admin Template profile.
77376-image.png


77415-image.png



I hope these screenshots are helpful.
Best regards.

0 Votes 0 ·
image.png (103.9 KiB)
image.png (70.8 KiB)
LuDaiMSFT-0289 avatar image
1 Vote"
LuDaiMSFT-0289 answered ·

@DatTruongManh-1313 Thanks for your feedback.

If you are interested in this feature on windows home device, it is suggested to feedback in intune user voice. This is a place to collect customers' requirements and problems.
https://microsoftintune.uservoice.com/forums/291681-ideas

At the same time, I will try my best to feedback to product team. However, I can't guarantee I'll get a reply from them.

Thanks for understanding and have a nice day.


If the response is helpful, please click "Accept Answer" and upvote it.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LuDaiMSFT-0289 avatar image
0 Votes"
LuDaiMSFT-0289 answered ·

@DatTruongManh-1313 Thanks for your update.

For this issue, I have done the test in my lab. The following pictures show my test:
Device OS build is 19042.867,version 20H2 and MDM enrolled.
Edge version is 89.0.774.54(64-bit)
77617-image.png
77643-image.png
The profile is deployed successfully to my device group, and the URLs are blocked.
77644-image.png
77674-image.png

So, we appreciate your help to try the following actions:

  1. Please update the Edge and deploy the profile again.

  2. Please enter "edge://policy" to check if there is any other policy causing this situation.
    77547-image.png

If there is any update, feel free to let us know.


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (80.5 KiB)
image.png (71.5 KiB)
image.png (38.6 KiB)
image.png (71.0 KiB)
image.png (37.0 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DatTruongManh-1313 avatar image
0 Votes"
DatTruongManh-1313 answered ·

@LuDaiMSFT-0289 May I ask which edition of Windows you use in the screenshots? I find that this issue only occurs on Windows 10 Home, Home Single Language and Home N but not on Windows 10 Pro, Education or Enterprise regards the OS build number.

I updated Edge to latest version, 89.0.774.54, but the issue remains the same. I verified that the version and OS build of the 2 test machines are identical, 20H2 and 19042.867, the only difference is their OS edition, one is Windows 10 Pro, and the other is Windows 10 Home Single Language.

Furthermore, the configuration profile for Chrome ADMX behaving as Edge's, but Intune only displays Chrome's profile as "Not Applicable" with "No data".

The followings are the screenshots from my test machines and Intune report.

77648-image.png
77657-image.png
77658-image.png
77659-image.png



Is there anything more you need to help investigate?
Best regards.


image.png (207.6 KiB)
image.png (364.8 KiB)
image.png (72.7 KiB)
image.png (96.8 KiB)
· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@DatTruongManh-1313 Sorry, I forgot that this issue just occurs on Windows 10 Home devices. Please ignore my test information.

I don't have Windows 10 Home devices to do this test. For this strange situation, it is suggested to do more check to confirm. With Q&A limitation, we suggest to open a case to check on this. It is free. The following link describes how to open a case, we can refer to it:
https://docs.microsoft.com/en-us/mem/intune/fundamentals/get-support

Hope it will help.

1 Vote 1 ·
DatTruongManh-1313 avatar image
0 Votes"
DatTruongManh-1313 answered ·

Update for the issue:
I recently sent the ticket to Microsoft. They states that ADMX is not supported on Home edition, only Pro and Enterprise edition due to Group Policy Editor (gpedit.msc) is not available to Home edition devices: https://docs.microsoft.com/en-us/deployedge/configure-microsoft-edge
80157-image.png

So I conducted a test that if the GP Editor is enabled on a Home device, will the ADMX be successfully sent? Turns out the result is still the same as this issue.

Maybe in the near future Microsoft might allow browser management on Home edition?



image.png (43.4 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.