question

PCProfiSA-1921 avatar image
0 Votes"
PCProfiSA-1921 asked KarlieWeng-MSFT commented

Really slow copy paste of file with remote desktop gateway, RDS Client standard KO RDS Client Classic from STORE OK

Hello,

I have a RDS installation on windows server 2019 with a RDS Gateway to connect to a RDS 2019 hosts farm.

When I'm using MSTSC (legacy client), or last version of Microsoft RDS Client : https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/windowsdesktop

The copy paste of fileis reaaaaalllyyy slow, even for a 2 mbytes files.

If i'm connecting locally to the RDS host all is fine.

With the classic client from store :
https://www.microsoft.com/en-us/p/microsoft-remote-desktop-classic/9nblggh30h88?activetab=pivot:overviewtab

The speed is perfectly fine.

But I don't want to use the Store Client, as it's impossible to deploy it, and it's not a supported version on the long time.

I already tried to disable UDP on my gateway, and on My client
I also tried to disable URCP (Universal Rate Control Protocol)

I can't work with UDP because of layer 7 LoadBalancer in Frontend.

If someone has same experience, I will be grateful !!

Have a nice day.

remote-desktop-serviceswindows-server-2019
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

PCProfiSA-1921 avatar image
0 Votes"
PCProfiSA-1921 answered

With a collegue we had a more deep analysis of the problem.

When we have the problem, on the RD Gateway we are seeing that the transport method ist HTTP which is RDP 8

If on the client we create the DWord RDGClientTransport and we set it to 1 in HKLM\Software\Microsoft\Terminal Server Client

The client is now using RDP 7 and on the RDG gateway we see that transport is RPC-HTTP, in this case the fluidity is a bit less, but the copy file is perfectly fine.

Can some one explain, why the hell the HTTP way is sooo slow for copy paste ?

Have a nice day.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KarlieWeng-MSFT avatar image
0 Votes"
KarlieWeng-MSFT answered KarlieWeng-MSFT commented

Hello @PCProfiSA-1921

Try to change security layer to "RDP Security Layer" , and the encryption level to High instead of negotiate

open Local Group Policy Editor, expand Computer Policy > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host, and then click on Security.

78641-image.png

Reference thread:
RDP File transfer is really slow. Any way to speed it up?
File transfer via RDP is slow



Best Regards
Karlie


If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (56.8 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @PCProfiSA-1921

Have you checked if above answers help?
If they are helpful, please do not forget to accept the answers.

Have a good day !

Best Regards

0 Votes 0 ·