question

YiruChen-1261 avatar image
0 Votes"
YiruChen-1261 asked ·

IM policy - retention does not work?

I have a simple library in SPO, just the base Document content type. and created a IM policy on retention on "Document" content to following

Created + 1 day

Transfer to another location (move and leave a link)


It worked for one file at this library, it did get moved to the destination library after 1 day (uploaded on March 11 and moved on March 12 and the file now has a link)

I have uploaded a file yesterday 3-15 at 11 am but that file is still in the library now at 3-16, 12:07 pm , nothing happened. Since it is in SharePoint Online, I am not able to check job status.

Is anything wrong? Is the related jobs running properly in SPO?

office-sharepoint-online
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

EmilyDu-MSFT avatar image
0 Votes"
EmilyDu-MSFT answered ·

@YiruChen-1261

In the SharePoint Online, the related jobs automatically run in the back end.

1.Make sure the file belongs to Document content type. Go to classic experience library -> Select the file -> Click ellipsis -> Advanced -> Compliance Details to check content type and retention policy.
2.Please upload some files into library to test whether the retention policy works.
3.If the issue persists, try to re-create the retention policy.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 3 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I checked file Compliance Details, it shows:

Retention Stage (acquired from content type)

Event: Created + 1 day Action: send to Records Repository, Recurrence: no, scheduled occurrence: 3/16/2021


But nothing happens so far (today is 3/17/2021, 3:55 pm), the file still sits in the original library.

0 Votes 0 ·

@YiruChen-1261

Please go to SharePoint admin center -> Records management feature -> Check whether Send To Connection is correct and valid.

I suggest you open a service request with Microsoft.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




0 Votes 0 ·

Documents eventually routed to the destination according to IM policy > retention stage, but it is a 5 day delay: according to Compliance Detail, the move is supposed to occur on 3/16, but it happened on 3/21

0 Votes 0 ·