question

sns1 avatar image
0 Votes"
sns1 asked JulieWang-MSFT commented

freuqent alerts saying app pool disabled

freuqent alerts saying app pool disabled.
upon checking event logs, I found information mentioned in the attached logs
Please help. why it happened? and what we have to do to avoid this alerts
we have 2 WFE and 2 APP. this alerts are on one of the web front end.
Please find attached event logs
78509-eventlogs.txt


office-sharepoint-server-administration
eventlogs.txt (6.0 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

trevorseward avatar image
0 Votes"
trevorseward answered trevorseward commented

Looks like there is an issue on the IIS site preventing the config from being read. One of the easiest ways to identify what lines are an issue is to go to the IIS site in question and then view Authentication. If it throws an error, it typically tells you what line is a problem.

Another thing to try is on the problematic server:

$wa = Get-SPWebApplication https://problemUrl
$wa.Unprovision()
$wa.Provision()


This will remove and then re-provision the web application and associated IIS pool (unless that IIS pool is used by other Web Applications, then you'll want to stop/start the Foundation Web service which will de-provision/re-provision all Web Apps/IIS pools on that server).

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Seward,

Thank you for the response.

I have navigated to respective site, Please find below screenshot. how do we find which line is having a problem from below screenshot, and what is the error it is showing? and how do we fix it?
79003-capture.jpg

second question:
if we unprovision and provision it will impact production site right? do we need to take down time?
Please help further.


0 Votes 0 ·
capture.jpg (80.5 KiB)

Looks like that config is OK.

Yes, performing an Unprovision/Provision will take down the IIS site associated with the Web App as well as any IIS site attached to the IIS App Pool that Web App uses. Using Unprovision/Provision will only take down the Web App on that particular server.

0 Votes 0 ·
JulieWang-MSFT avatar image
0 Votes"
JulieWang-MSFT answered JulieWang-MSFT commented

Hi @sns1,

Please go to C:\inetpub\temp\appPools to check if there was a corrupted shortcut with the name of your site.

If true, delete the shortcut and restart the site to check whether a folder with the site name and a .config file is created in it.

Similar issue for your reference:

https://stackoverflow.com/questions/47518974/503-service-unavailable-trying-to-read-configuration-data-from-file

Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Wang,

This is what I see.
79215-capture.jpg


0 Votes 0 ·
capture.jpg (82.0 KiB)

Hi @sns1,

There seems to be no interrupted shortcut, can you access the site without barriers or have an http 503 error?

Delete the directory (or virtual directory) with the same name as your app pool.

Restart the App Pool again to compare the result.(This will recreate the directory automatically)

Similar issues:

https://techcommunity.microsoft.com/t5/iis-support-blog/http-503-with-trying-to-read-configuration-data-from-file-error/ba-p/308515

https://serverfault.com/questions/881870/error-on-iis-app-pools-after-upgrading-from-windows-server-2013-to-windows-serve

0 Votes 0 ·

Hi @sns1,

I’m checking how the things are going on about this issue. Whether the post helps you?

You can accept the post as answer if it helps.

Thank you for your understanding and support.

0 Votes 0 ·
sns1 avatar image sns1 JulieWang-MSFT ·

Hi Wang,

Still we are seeing alerts.

There is no any barrier or 503 error when we browse the site.
we have 2 WFE and 2 APp, memory comsumption is 55, 65, 75 and 85 percent in all these 4 servers ( 75 and 85 are app servers)

Below is the alert message:


The server was unable to allocate from the system nonpaged pool because the pool was empty
.from one of the app server.

Please help.

0 Votes 0 ·

Hi @sns1,

Please check the latest answer.

0 Votes 0 ·
JulieWang-MSFT avatar image
0 Votes"
JulieWang-MSFT answered JulieWang-MSFT commented

Hi @sns1,

From the alert message, which means your server is under a heavy load, the Server service may repeatedly log it in the System Event log. It indicates that the server is out of paged pool memory.

To solve this issue, set the value at 60 informs the Memory Manager in following registry to start the trimming process at 60 percent of PagedPoolMax rather than the default setting of 80 percent.If a threshold of 60 percent isn't enough to handle spikes in activity, reduce this setting to 50 percent or 40 percent.

 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management

Restart the server for the changes to take effect.

Note:

Serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it.

More information for your reference:

https://docs.microsoft.com/en-us/troubleshoot/windows-server/performance/unable-allocate-memory-system-paged-pool


· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Wang,

where to check current value which is 80? 82381-capture.jpg
Please find attached screenshot. which I should pick up and modify in the middle of the screen?
do we need to modify in all servers in farm?


0 Votes 0 ·
capture.jpg (131.8 KiB)

Hi @sns1,

Modify it in the affected server.

On the Edit menu, click Add Value, and then add the following registry value:
Value name: PoolUsageMaximum
Data type: REG_DWORD
Radix: Decimal
Value data: 60


0 Votes 0 ·
sns1 avatar image sns1 JulieWang-MSFT ·

Hi Wang,

I can see New option not add value. PFA82259-c2.jpg


0 Votes 0 ·
c2.jpg (83.7 KiB)
Show more comments