question

AmitDhawan-7952 avatar image
0 Votes"
AmitDhawan-7952 asked tlecouffe commented

API NOT found error IoT Central Rest API


I get below error:-

Not Found({"error":{"code":"NotFound","message":"API not found. If you contact support, please include the following information. Request ID: 8srjji57, Time: Thu, 04 Jun 2020 04:32:05 GMT.","requestId":"8srjji57","time":"Thu, 04 Jun 2020 04:32:05 GMT"}})


The api im using is below

az rest --method get --uri https://$APP_NAME.azureiotcentral.com/api/preview/applications --headers Authorization=$API_TOKEN


The document Im following is below

https://docs.microsoft.com/en-in/learn/modules/manage-iot-central-apps-with-rest-api/3-exercise-authorize-api


not-supported
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Same thing happening to me.. were you able to resolve?

0 Votes 0 ·

1 Answer

AmitDhawan-7952 avatar image
0 Votes"
AmitDhawan-7952 answered tlecouffe commented

No, and no one from Microsoft helped either.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I ended up just continuing to the next part, and the API_TOKEN, and commands there worked. I'm thinking that particular one is malformed or deprecated. It didn't seem to block moving forward. Best not waste too much time one that one :)

1 Vote 1 ·